1995 Oldsmobile Cutlass fuel pump

Tiny
JIMIJOEBOB2002
  • MEMBER
  • 1995 OLDSMOBILE CUTLASS
  • 3.1L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 25,000 MILES
I bought a new fuel pump relay but still have no power to the fuel pump. I checked under the relay and I have only one hot wire it's red in color the feed I think. Shouldn't there be power coming out of the relay?
Do you
have the same problem?
Yes
No
Friday, October 3rd, 2014 AT 1:09 PM

7 Replies

Tiny
JIMIJOEBOB2002
  • MEMBER
That's one hot red wire with the key in run. I unhooked the feed to the pump back at the tank and have no power there with the engine cranking.
Was this
answer
helpful?
Yes
No
Friday, October 3rd, 2014 AT 1:17 PM
Tiny
HMAC300
  • EXPERT
Check ecm/bat fuse underhood first the red wire operates with the key to prime the pump. It sends power to the gray wire which goes to pump. After that the orange wire is hot after car is running. If not fuse is blown like the ecm /bat fuse then check to seeif power goes to orange wire. The other wires are tan which goes to ground on transmission stud so clean that and dk/green from pcm which commands pump on. You might see if your connections are good in fuse box and tweeking the prongs on relay to make sure it makes contact. Adding dielectric grease would help as well. It may be just a bad fuse box connection as well.
Was this
answer
helpful?
Yes
No
Friday, October 3rd, 2014 AT 1:45 PM
Tiny
JIMIJOEBOB2002
  • MEMBER
Witch one is the ecm/ bat fuse? I don't have fuse box covers and have no idea what fuse is for what. Do have a pic of the fuse boxes.
Was this
answer
helpful?
Yes
No
Friday, October 3rd, 2014 AT 2:39 PM
Tiny
JIMIJOEBOB2002
  • MEMBER
I checked all the fuse's under the hood and they are all good.
Was this
answer
helpful?
Yes
No
Friday, October 3rd, 2014 AT 3:02 PM
Tiny
HMAC300
  • EXPERT
Hen check the other stuff I said in first reply either a volt meter or test light
Was this
answer
helpful?
Yes
No
Friday, October 3rd, 2014 AT 3:42 PM
Tiny
JIMIJOEBOB2002
  • MEMBER
Hi well I now have power were I should under the relay but I still have no power to the pump. I am going to run a new wire from the relay to the pump and see if that works. Going to check that ground too.
Was this
answer
helpful?
Yes
No
Friday, October 3rd, 2014 AT 4:46 PM
Tiny
HMAC300
  • EXPERT
It's the gray wire leading to pump to power it. Check ground at tank.
Was this
answer
helpful?
Yes
No
Saturday, October 4th, 2014 AT 5:39 AM

Please login or register to post a reply.

Recommended Guides