My 94 Saturn bangs when you put it in reverse !

Tiny
ROBERT TARTER
  • MEMBER
  • 1994 SATURN SL1
  • 135,000 MILES
It bangs when you put it in reverse and don't want to pull in drive but you can turn it off and back on and it won't do it! And when it Does this my check engine light comes on! But my car does not do this every time I drive it! Is it a sensor or a linkage?
Do you
have the same problem?
Yes
No
Monday, February 13th, 2012 AT 1:32 AM

8 Replies

Tiny
SATURNTECH9
  • EXPERT
Its not a sensor or linkage. Do you have a delay then bang into reverse?What codes do you have?Sounds like a line pressure issue in the transmission. Really common on those cars.
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 1:53 AM
Tiny
ROBERT TARTER
  • MEMBER
It Does delay before it jerks and that's what I'm trying to figure out is the codes. What would be a good way to fix it?
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:04 AM
Tiny
SATURNTECH9
  • EXPERT
Lets start with the codes exact numbers I need?Also you will need to do a line pressure test in park with the line pressure fuse in and out. Would you like me to recommened a presure set?My set is less then 70 and its really nice I used it many times.
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:13 AM
Tiny
ROBERT TARTER
  • MEMBER
Could my transmission filter be stopped up! What could the pressure to be low he that's the case!
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:19 AM
Tiny
ROBERT TARTER
  • MEMBER
WHere are the transmission fuses located?
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:21 AM
Tiny
SATURNTECH9
  • EXPERT
I really doubt your transmission filter is plugged up causing this. Its most likely the pressure regulator failing inaide the valve body. We have to check the line pressure with a gauge the transmission fuses are in the underhood fuse box.
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:24 AM
Tiny
ROBERT TARTER
  • MEMBER
Could it be transmission oil sensor?
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:33 AM
Tiny
SATURNTECH9
  • EXPERT
The transmission temp sensor wouldnt cause the problems your having. Its a transmission line pressure issue I know these transmissions well have worked for saturn working on these for over 16yrs. We need to check the pressure and see what codes we have.
Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 2:54 AM

Please login or register to post a reply.

Recommended Guides