1994 Mercedes Benz C220 has no Pulse on injector#2

Tiny
SPENCERWITTU
  • MEMBER
  • 1994 MERCEDES BENZ C220
  • 209,000 MILES
1994 mercedes benz c220 has no pulse on injector#2 it has 12v no neg pulse.I have replaced ecm
Do you
have the same problem?
Yes
No
Monday, October 15th, 2012 AT 7:26 PM

10 Replies

Tiny
KHLOW2008
  • EXPERT
Did you check the wiring to ECM for continuity? The wire could have a break in between.
Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 8:02 PM
Tiny
SPENCERWITTU
  • MEMBER
THANKS FOR RESPONSE, YES IT HAS CONTINUITY NEG TO ECM AND POS HAS 12V
Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 8:16 PM
Tiny
KHLOW2008
  • EXPERT
Such symptoms can only indicate a bad ECM.

Did you check for trouble codes?
Was this
answer
helpful?
Yes
No
-1
Monday, October 15th, 2012 AT 8:36 PM
Tiny
SPENCERWITTU
  • MEMBER
I put a used ecm in and have the exact problem inj#2 only no pulse so was this ecm bad or did something burn this one up instantly. Meaning after install of ecm car never ran right not even for a second?
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 12:03 AM
Tiny
KHLOW2008
  • EXPERT
If you have a short in the circuit, it can short out the ECM.

Did you test if the injector is working?
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 7:58 AM
Tiny
SPENCERWITTU
  • MEMBER
Yes, injector is clicking just fine also I ran a new neg wire from ecm to injector bypassing any possible short. When you put a testlight on positive batt then touch to neg inj wire to ecm light does light up dim like not 12v but grounding out. Only #2 inj wire. With noid light it will not blink or stay on no light at all?
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 6:52 PM
Tiny
KHLOW2008
  • EXPERT
You should not be doing that. You can damage the ECM. But then again the ECM seems to be faulty if it is not pulsing.
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 6:57 PM
Tiny
SPENCERWITTU
  • MEMBER
Yes, can the inj. Driver go to full ground like stuck. Iits odd that two ecm's would do the same thing?
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 7:03 PM
Tiny
KHLOW2008
  • EXPERT
Usually when there is a design flaw, the same problem can occur for components of the same batch after a certain period of usage so not really surprising.
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 7:10 PM
Tiny
SPENCERWITTU
  • MEMBER
Yes I could see that. Now with the test light isn't that the same principal as plugging in a noid light. And I do really appriciate your help.
Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 7:25 PM

Please login or register to post a reply.

Recommended Guides