Cold start issue

Tiny
1989HAWKGT
  • 1993 VOLVO 850
  • 5 CYL
  • 2WD
  • AUTOMATIC
  • 240,000 MILES

Can anyone tell me what the fuel pressure should be before start-up & if it is supposed to increase or decrease after start up. I am reading around 43psi before start-up & around 40psi while running.
Thank you in advance!

Do you
have the same problem?
Yes
No
Wednesday, March 9th, 2011 AT 5:33 PM

30 Replies

Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Fuel pressure good is there a running problem?

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 5:43 PM
Tiny
1989HAWKGT
  • MEMBER

Car will not start up if under 60 degrees, tries to start then dies. Seems like no fuel enrichment. If over 60 degrees & engine is cold there is no fast idle drops right to 700/800 rpms.

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 5:48 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Most likely faulty coolant temp sensor not signaling ECM off cold engine and not riching fuel mix

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 5:54 PM
Tiny
1989HAWKGT
  • MEMBER

That was my initial thought. I just replaced it yesterday

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 5:57 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

So did it help? Have tried a good fuel system cleaner?

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 6:11 PM
Tiny
1989HAWKGT
  • MEMBER

To your 1st? No, replacing the coolant temp sensor did not help. Engine will eventually run & it does drive, just hard to get started if outside temp is low. At first try idle jumps to around 1800 rpm then dies. If you wait 20 seconds or so it will do the same thing over & over again until the heads get some heat then it will keep running & drive fine. I guess some fuel injector cleaner couldn't hurt but just doesn't seem to be what's causing the problem.

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 6:22 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Has Idle air controler been removed and cleaned? Has MAF been cleaned?

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 6:29 PM
Tiny
1989HAWKGT
  • MEMBER

I will clean IAC. It seems to move freely. Mass airflow sensor has also been replaced. I can't get to it right now due to pouring rain but I will get to it asap. Anything else you can thing of would be appreciated & I will tackle them one at a time. Thanks & you assistance is greatly appreciated. I am trying to fix this for an elderly couple whom don't have any extra money to get it fixed. I am paying for parts myself. Thanks again!

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 6:43 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Have tried diagnostic test unit for possible codes?

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 6:58 PM
Tiny
1989HAWKGT
  • MEMBER

Don't know of anyone whom has a tester for that old of a car. I see there is a DLC in front of the computers, how is that used. Looks like a place to test several different functions.

Was this
answer
helpful?
Yes
No
Wednesday, March 9th, 2011 AT 7:59 PM
Tiny
1989HAWKGT
  • MEMBER

I have not gotten a response from the last? I did clean the Idle Air Control & didn't help any. Can anyone out there help me?

Was this
answer
helpful?
Yes
No
Thursday, March 10th, 2011 AT 8:31 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Diagnostic unit in front of right strut tower #2 for injecor test #6 for ignition push button for 1 sec no more than 3 sec LED will flash. There will be 3 sec interval between flashes so flash, flash pause flash, pause flash, flash=212
do both #2 and #6 post codes

Was this
answer
helpful?
Yes
No
Thursday, March 10th, 2011 AT 8:40 PM
Tiny
1989HAWKGT
  • MEMBER

No codes appear on #2 & #6. Also the cooling fan now runs after 2 minutes of running. A/C is off Fan keeps running for a couple of minutes after shut down. This just started after I replace the Coolant Temp Sensor.

Was this
answer
helpful?
Yes
No
Thursday, March 10th, 2011 AT 8:59 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Unplug ECT see if fan stays off. With no codes not much help how is overall performance? Does it move off and run cold? What is engine compression? Try SeaFoam to clean fuel system at 240K and 19yrs think it could help. Carbon build up on intake valves will absorb fuel starving cylinder

Was this
answer
helpful?
Yes
No
Thursday, March 10th, 2011 AT 9:23 PM
Tiny
1989HAWKGT
  • MEMBER

Do not understand ECT. I unplugged cooling fan relay just to keep from running down battery. Also fan in computer panel/box runs with cooling fan.

Was this
answer
helpful?
Yes
No
Friday, March 11th, 2011 AT 3:10 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

ECT engine coolant temp sender see if fan quits

Was this
answer
helpful?
Yes
No
Friday, March 11th, 2011 AT 4:12 PM
Tiny
1989HAWKGT
  • MEMBER

No change after unplugging temp sensor, fan continues to run. Also when turning on ignition the IAC opens fully - is that normal? I checked for high resistance on the three terminals 10.4, 11.8, & 21 ohms

Was this
answer
helpful?
Yes
No
Friday, March 11th, 2011 AT 5:27 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Suspect PFI control module to be at fault for both problems

Was this
answer
helpful?
Yes
No
Friday, March 11th, 2011 AT 5:42 PM
Tiny
1989HAWKGT
  • MEMBER

I was hoping that wasn't the issue. Is the pfi still available & is this an Volvo dealer only item?
I want to THANK YOU for all your help

Was this
answer
helpful?
Yes
No
Friday, March 11th, 2011 AT 5:47 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,004 POSTS

Not sure Volvo would have check out used parts dealers and threr are companys that repair computers for cars

Was this
answer
helpful?
Yes
No
Friday, March 11th, 2011 AT 6:01 PM

Please login or register to post a reply.

Recommended Guides