DRIVING MY CAR LOST ALL POWER CONNECTED WITH ACCELERATOR

1993 Toyota Starlet

Tiny

Charliechaplin

February, 21, 2012 AT 7:11 PM

Hi, although engine is still running I cant move at all accelerator wont do anything. No revs nothing just sits there and idles also I woke to find a massive patch of oil this morning could you please give me ideas as to what this may be?

FOUND 2975 RELATED QUESTIONS

6 Answers

Tiny

rasmataz

February, 21, 2012 AT 7:14 PM

Is this an auto or manual transmission?

Tiny

Charliechaplin

February, 21, 2012 AT 7:37 PM

Auto sorry

Tiny

rasmataz

February, 21, 2012 AT 7:41 PM

Have the transmission checked for slippage if okay-test the airflow meter and throttle position sensor

Tiny

Charliechaplin

February, 21, 2012 AT 7:42 PM

Okay thank you very much ill get on to that today cheers mate

Tiny

Charliechaplin

February, 21, 2012 AT 9:31 PM

Hi I Just checked the trans fluid itself and its empty like bone dry empty I just went down and put some ATF multi purpose in could this be the reason behind it all i've had it over a year and never checked it and it was sitting in a yard for 7 years should I risk driving it and see how it goes or take it in to the mechanics sorry to bother you I would rather not take it in if its something I can do

Tiny

rasmataz

February, 21, 2012 AT 10:40 PM

If its moving with no problem-If you wish to continue driving it-try changing fluid and filter and go from there

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
Read Codes Like a Pro
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear
How to gather codes Ford Explorer
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear - Dodge Stratus