1993 CHEVY K1500

  • Tiny
  • Mcmsargent
  • 1993 CHEVROLET
  • V8
  • 4WD
  • AUTOMATIC
  • 150,000 MILES

My brothers 1993 Chevy 1500 4x4 with a 350 quits running after 20- 25 minutes. It just shuts off. Was wondering if it could be the ignition module or coil?It also has a hard time starting back up after he lets it sit for a few minutes to cool down.

Do you
have the same problem?
Yes
No
Thursday, April 7th, 2011 AT 10:47 PM

1 Reply

  • Tiny
  • Rasmataz
  • MEMBER

Next time it refuses to start don't wait for it to make up its mind-do below immediately to determine if its fuel or spark problem

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if okay-check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, cap and rotor, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing

Was this
answer
helpful?
Yes
No
Thursday, April 7th, 2011 AT 10:53 PM

Please login or register to post a reply.

Other Ignition Module Questions