93 3800 Lesabre cranks but ownt start

Tiny
TOMSTEVE
  • 1993 BUICK LESABRE
  • 120,000 MILES

Ok, this is a friends and I dont know much about buicks. The car cranks over strong, theres spark. Cant say how good as it was late, dark, and raining when he called( used a screwdriver in a plug wire) and I went to see what I could do. He had drained the battery so I jumped it. It rolls over strong but acting like no fuel. He says this happened once last spring and the car had to sit for a few days before it would start, then didnt have a problem til tonight. One thing I did was disconnect the ground on the battery( and I cant even remember why, but there was a reason) and after I hooked it back up, it sputtered for a second then nothing.
any suggestions on where to start?

Do you
have the same problem?
Yes
No
Sunday, October 14th, 2012 AT 1:12 AM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,554 POSTS

Check fuel pressure first.

Roy

Was this
answer
helpful?
Yes
No
Sunday, October 14th, 2012 AT 1:18 AM
Tiny
TOMSTEVE
  • MEMBER

Im at 42 psi.

Was this
answer
helpful?
Yes
No
Sunday, October 14th, 2012 AT 6:45 PM
Tiny
TOMSTEVE
  • MEMBER

Got it runnin. Unplugged the mass air flow sensor and the other 2 connections by it and it fired right up. Pulled the mass air flow sensor and cleaned it with mass air flow cleaner. Thinkin a new one is in order.

Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 12:53 PM

Please login or register to post a reply.

Other Engine No Crank Over Questions