My S-10 is having elecrical issues

Tiny
HSWANSON
  • 1992 CHEVROLET S-10
  • 189,000 MILES

My S-10 is having elecrical issues. When I press the brake pedal the parking lights come on no brake lights, and the buzzer that lets you know your headlights are on sounds. Also the digital clock on the stereo gets dim and blinks on and off when I turn on the turn signal. I know this is a short of some kind but I've checked the brake switch by bypassing it with a wire thats not the problem. I've also checked all the bulbs for shorts all are good. What could this be?

Do you
have the same problem?
Yes
No
Saturday, November 3rd, 2012 AT 2:28 PM

4 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,476 POSTS

Bulbs or sockets have a short. Re check them to see which has failed.

Roy

Was this
answer
helpful?
Yes
No
Saturday, November 3rd, 2012 AT 2:31 PM
Tiny
HSWANSON
  • MEMBER

Definitely will do thanks, could this be a turn signal switch?

Was this
answer
helpful?
Yes
No
Saturday, November 3rd, 2012 AT 2:37 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,476 POSTS

Not really. I would look at bulbs

Roy

Was this
answer
helpful?
Yes
No
Saturday, November 3rd, 2012 AT 2:46 PM
Tiny
POPPASMURF
  • MEMBER

Check the grounds on both tail lights. A faulty or missing ground will cause current to the brake lights to feed back through the tail circuit which would cause the parklight to show as on.

Was this
answer
helpful?
Yes
No
Sunday, December 9th, 2012 AT 1:32 AM

Please login or register to post a reply.

Recommended Guides