1991 Ford Taurus EGR code

  • 1991 FORD TAURUS
  • 5 CYL
  • FWD
  • 140,000 MILES

1991 Ford Taurus, mileage: 140,000. My car has a pressure feedback electronic (PFE) EGR system. The code 332 (insufficient EGR flow) will set after the engine warms up, and the EGR valve is supposed to open. Emissions manual recommends replacing the PFE transducer (9J460), but it seems to be working correctly, there seems to be no flow in the EGR system. I ran a functional test on the EGR valve 9D475, by applying a vacuum to the valve while monitoring idle RPM on a hot engine. With ten inches of vacuum applied, idle speed did not change, so I thought the EGR valve was bad. I removed the valve and inspected it. It was clean, and opened fully with only four inches of vacuum applied. It stayed open with no vacuum leak. I blew backwards into the exhaust system through the EGR inlet tube. It was also wide open. I blew into the controlled pressure inlet to the PFE valve, and that was open. I also pushed a wire through it. Then I tried to blow into the intake manifold, and that seemed to be blocked. I forced a heater hose into the EGR opening in the intake manifold, and tried to blow into it again, without success. I connected the hose to an air compressor, and tried to force compressed air into the intake manifold, but was again unsuccessful. Then I tried to push a wire into the intake manifold, but could only push it a short distance, where it was always stopped by some obstruction. I removed the intake air hose, and opened the throttle plate, and looked into the intake manifold. It seems to be carboned-up. But is it possible that there could be so much carbon in the manifold, that the EGR is completely blocked? Or am I looking in the wrong place, and for some other reason, the intake manifold is not open at this point? I would appreciate any help that I can get from somebody here, before I remove the intake manifold.

Do you
have the same problem?
Tuesday, February 1st, 2011 AT 10:24 PM

1 Reply


Sounds like the EGR port in the intake manifold is plugged.&Nbsp;

Response: Yes, it was plugged. It was blocked with rather hard carbon. I used a coat hanger wire with a hook on the end to drag the carbon out of the port. Now the light is out. Thanks for your response.

Was this
Tuesday, February 1st, 2011 AT 10:27 PM

Please login or register to post a reply.

Recommended Guides