CAR STARTS BUT ENGINE VIBRATES, WHEN ACCELERATES, CAR VIBRATES MORE ,SOUNDS LIKE A MISS, IN DRIVE,CAR CREEPS.

1990 Suzuki Sidekick

Tiny

Joh

December, 30, 2011 AT 11:30 PM

Car starts, but idles rough and vibrates, press to accelerate, sometimes it revs, but when I put it in drive, no power, it goes very slow and vibrates and sounds like its missing.I took compression test, all 160 to 165 psi, all spark plugs firing, all fuel injectors working, I moved the distributor all the way left slowly, and all the way right slowly, I put in new spark plugs and took them back out twice, they were sooty black, clean them still sooty black, what should I try next? This really need some help. My friend says its the PCM (computer).
But I did not take it out. Also car has automatic transmission.

FOUND 684 RELATED QUESTIONS

6 Answers

Tiny

rivermikerat

December, 31, 2011 AT 3:48 AM

See if there are any hard or soft codes. Is there any smoke from the tailpipe? Black soot is carbon buildup, usually either too much fuel or oil. Does it lose oil? Disconnect the oxygen sensor and see if any difference is made. Next, disconnect the mixture control solenoid (on the carburetor) and see if it makes any difference.

Tiny

Joh

December, 31, 2011 AT 10:04 PM

No codes, its a suzuki side kick, 1990, have injectors, already disconnected oxygen sensor, still behaves the same way, vacuum test is normal at 22 and steady, took out air filter, idles ok for now, but when I press the accelerator, no power, put it in drive, it creeps.

Tiny

rivermikerat

January, 1, 2012 AT 1:28 AM

Throttle cable connected? Throttle butterfly opening?
Does the engine accelerate but there's no transfer of power to the wheels? Or will the engine not accelerate?

Tiny

Joh

January, 8, 2012 AT 8:52 PM

Yes cable is connected, butterfly open all the way, there is transfer of power to the wheels, but when I press on the gas pedal no power, just creeps.

Tiny

rivermikerat

January, 9, 2012 AT 8:18 AM

Does the engine rev up? If so, the transmission is most likely slipping. Check the fluid level and condition. You want it red and not smelling like it's burned.
If not, you might have a plugged catalytic converter. Install a straight pipe in place of the converter and drive it. Power back? Replace the cat.

Tiny

rivermikerat

January, 31, 2012 AT 8:46 PM

Joh, did you get this transmission issue fixed? Do we need to keep looking into diagnostics?

Please login or register to post a reply.

Brake Light Bulb Replacement Mercedes Benz
Headlight Bulb Replacement Volkswagen Jetta
Wiper Blade Replacement Chrysler PT Cruiser
Reverse Light Bulb Replacement Chevrolet
Headlight Bulb Replacement Acura MDX