Oil pressure

Tiny
DARRENTEX
  • 1990 MAZDA B2600
  • 4 CYL
  • 4WD
  • MANUAL

My ute has no oil pressure I have removed the ballance shaft chain would that hav anything to do with not having oil pressure

Do you
have the same problem?
Yes
No
Thursday, January 27th, 2011 AT 9:05 AM

11 Replies

Tiny
DOCFIXIT
  • EXPERT
  • 19,035 POSTS

Oil pump is driven by crankshaft so no too balance shaft chain off my question is why remove baklance shaft chain?

Was this
answer
helpful?
Yes
No
Thursday, January 27th, 2011 AT 7:33 PM
Tiny
DARRENTEX
  • MEMBER

The chain I was given by the REPCO store is the corect chain but it is to long the old one had broken due to a joiner link in the chain and I was told buy 3 machinacs that it would happen again if I was to shorten it by removing links out of chain I had started my ute and had it runing for no more than 5 min and I still hav an oil light on dash board and thr is the corect amount of oil in engine

Was this
answer
helpful?
Yes
No
Thursday, January 27th, 2011 AT 10:44 PM
Tiny
DARRENTEX
  • MEMBER

I have just dubble checked and all belts r tight al wireing is conected the oil pump was working before the balance shaft chain broke is there an internal oil pump?

Was this
answer
helpful?
Yes
No
Friday, January 28th, 2011 AT 5:34 AM
Tiny
DOCFIXIT
  • EXPERT
  • 19,035 POSTS

Pump turns when crank turns. Put mechanical oil gague in see what pressure is

Was this
answer
helpful?
Yes
No
+1
Friday, January 28th, 2011 AT 1:55 PM
Tiny
DARRENTEX
  • MEMBER

Thats not my model of engine the pressure relief valve is on top and horozontal of crank shaft pully and there is a spacer that fits inside the iner rotor around crankshaft

Was this
answer
helpful?
Yes
No
Friday, January 28th, 2011 AT 11:05 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,035 POSTS

What is engine size?

Was this
answer
helpful?
Yes
No
Saturday, January 29th, 2011 AT 5:12 PM
Tiny
DARRENTEX
  • MEMBER

2.6 is wht all engine stamp plates say

Was this
answer
helpful?
Yes
No
Saturday, January 29th, 2011 AT 10:32 PM
Tiny
DARRENTEX
  • MEMBER

Sory mate u prob got beta things to do thn answer my ******* questions but can u tell me whr the rotor button needs to be when al other timing marks are lined up and also whr the oil presure sender is thankyou

Was this
answer
helpful?
Yes
No
Monday, January 31st, 2011 AT 8:31 AM
Tiny
DARRENTEX
  • MEMBER

Al the advice for u was great I thank you just a few things that I have to fix eg a slight vibration from passenger side balance shaft and a few oil leaks that I didnt seal properly again thank you

Was this
answer
helpful?
Yes
No
Thursday, February 3rd, 2011 AT 9:33 AM
Tiny
DOCFIXIT
  • EXPERT
  • 19,035 POSTS

See pics for chain timing. Got oil pressure? Leaks around cover?

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Thursday, February 3rd, 2011 AT 5:31 PM
Tiny
DARRENTEX
  • MEMBER

Have oil pressure now and yea oil leaks just whr I havnt seald it properly I didnt use a gasget I used the goo n yea I think thats all iv done with the vibration is just havnt put the balance shaft in the right position

Was this
answer
helpful?
Yes
No
Friday, February 4th, 2011 AT 12:45 AM

Please login or register to post a reply.

Related Oil Pump No Pressure Questions

Recommended articles