Battery died 2 days after being fully charged & load tested at O'Riely's Auto Parts Store

Tiny
MASONH4206
  • MEMBER
  • 1990 BUICK REGAL
  • 162,386 MILES
My battery was just fine a few days ago until I tried to start my 1990 Regal which did not have enough voltage to start the engine. I took the battery to O'Reilly Auto Parts to have the battery fully charged. After the battery was charged I then took the car to O'Reilly's to have the alternator checked. They said from the read-out that the alternator was not at a full meter when in idle, but it was fine when I pressed on the alternator. The 90 Buick Regal then started just fine and ran for 3 days, and on the 4th day when I tried to start the car in the morning the battery was dead.

I would like to know if the solution to my problem could be both the battery and the alternator. If not could there also be something else that would cause the battery to drain besides interior/exterior lights being on (which they are not). Thanks in advance for your expert knowledge!

Henri Mason
858 215-0559 It is fine to call my cell number if you would like :-)
Do you
have the same problem?
Yes
No
Saturday, February 11th, 2012 AT 2:47 AM

1 Reply

Tiny
CADIEMAN
  • MEMBER
You have a battery draw. Something is staying on. Youll need a multi meter to test it u remove the negitive cable. Hook one lead to the wire and the other to the neg. Battery. Than check the milliamps. It shouldnt be over 30 ma. You have to start here.
Was this
answer
helpful?
Yes
No
Saturday, February 11th, 2012 AT 3:07 AM

Please login or register to post a reply.

Sponsored links