Stalls when engine is warm

Tiny
MARCELMARCEL
  • MEMBER
  • 1989 GMC SUBURBAN
  • 50,000 MILES
Starts and runs perfect for about 10 to 15 minutes, once the engine is warm it stalls. It will start back up after it has cooled down about 45 minutes. I have replaced the coil, fuel pump, distributor and everything in it, the wiring harness and plug going to the distributor. New computer, all temp sensors and every device of the smog system. When it won’t start there is no fuel or spark. Doesn’t throw any codes. It’s a 454 TBI fuel injected headache.
Do you
have the same problem?
Yes
No
Wednesday, October 12th, 2011 AT 3:36 AM

8 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked the ASD relay?
Was this
answer
helpful?
Yes
No
Wednesday, October 12th, 2011 AT 3:42 AM
Tiny
MARCELMARCEL
  • MEMBER
No I havent, I dont belive this car has one. But if there is one would you happen to know where I might find it?
Was this
answer
helpful?
Yes
No
Wednesday, October 12th, 2011 AT 3:49 AM
Tiny
JAMILBRODT
  • MEMBER
Check the crank sensor. The check engine light might not come on because the computer does not see the problem for what ever time it takes for it to realize hey there is a problem. Or you might have to find a really good scan so you can watch components data while it is running and when it shuts off and see whats going on.
Was this
answer
helpful?
Yes
No
Wednesday, October 12th, 2011 AT 3:51 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
You know, I would say yes, it has one. However, I just spent the last 15 minutes looking for its location on Mitchel. Even though it is listed, I can not find a wiring schematic showing it.
Was this
answer
helpful?
Yes
No
Wednesday, October 12th, 2011 AT 4:04 AM
Tiny
MARCELMARCEL
  • MEMBER
There is no crank position sensor on this car I have been looking for the ASD relay In the Haynes book but no luck. I'll keep looking online. This problem has he going crazy. Thanks for all your help.
Was this
answer
helpful?
Yes
No
Wednesday, October 12th, 2011 AT 4:20 AM
Tiny
ASEMASTER6371
  • EXPERT
Joe, it does not have one. Just a fuel pump relay.

Just to add, I have seen that the throttle body gasket leaks vacuum and causes a stalling issue. Check it to see if there is any leaking by spraying some carb cleaner around the base and if it changes the idle up or down, replace the gasket.

Roy
Was this
answer
helpful?
Yes
No
Thursday, October 13th, 2011 AT 1:39 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Thank you, ASE. Mitchel lists them everywhere for this vehicle but doesn't show anything in wiring schematics or locations. It drove me crazy!
Was this
answer
helpful?
Yes
No
Thursday, October 13th, 2011 AT 1:42 AM
Tiny
ASEMASTER6371
  • EXPERT
Yep, remember, we are working with engineers. Lol
Was this
answer
helpful?
Yes
No
Thursday, October 13th, 2011 AT 1:49 AM

Please login or register to post a reply.

Recommended Guides