Almost like its out of gas.

Tiny
LAT
  • MEMBER
  • 1987 CHEVROLET CELEBRITY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 77,000 MILES
1987 Chevrolet Celebrity
The car starts as it should and idles normal. After letting the car warm up drive at about no more than 40 mph the problems start. When giving it gas it's like it wants to stop. If I try to start it the car it will turnover but almost instantly die back out. After letting the car cool for about 1 or 2 hours I can start it back up. Still having the same sluggishness. Almost like its out of gas. Put a new fuel pump on new filter new plugs. I put a new coils. New PCM. And a new Ignition Module new oxygen senser.

LOST PLEASE HELP
Do you
have the same problem?
Yes
No
Friday, August 5th, 2011 AT 4:52 PM

36 Replies

Tiny
SATURNTECH9
  • EXPERT
Do you have any codes?Maybe you have a stuck egr valve?
Was this
answer
helpful?
Yes
No
Friday, August 5th, 2011 AT 5:12 PM
Tiny
LAT
  • MEMBER
No codes everything looks good until I drive it
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 9:29 AM
Tiny
SATURNTECH9
  • EXPERT
When its hot you need to check fuel pressure check for a sticking egr valve to start have you checked for codes or are you saying no because the check engine light isnt on?
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 2:37 PM
Tiny
LAT
  • MEMBER
I took the wire off the trans. That is the wires to the torque converter and it is working OK now. Could it be the solenoid in the trans.
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 4:25 PM
Tiny
LAT
  • MEMBER
Me agian went for a drive in the car after takeung the wires to the torque converter off went for about 45 min to 1 hr. Went ok then died will not start untill it cools off. How do you check the codes
lost agian.
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 6:32 PM
Tiny
LAT
  • MEMBER
Check engine light isnt on
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 6:32 PM
Tiny
LAT
  • MEMBER
Dont know what to do now
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 6:33 PM
Tiny
SATURNTECH9
  • EXPERT
It could be have you tried to check for codes yet?
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 6:33 PM
Tiny
SATURNTECH9
  • EXPERT
I posted how to get the codes and how to clear them see what codes you have but you set codes by running the car with connectors unplugged. Let me know what codes you find.
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 6:47 PM
Tiny
LAT
  • MEMBER
Ok I checked the codes the only code that came up was code 12
flash pause flash flash.
You said that you set codes by running the car with connectors unplugged. Car will start then die wont keep running
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2011 AT 9:30 PM
Tiny
SATURNTECH9
  • EXPERT
Yes depending on which connectors are unplugged it will set codes because the computer will see a problem with the circuit thats how the computer knows to set the code in the first place. So do we have spark when it wont start to all the plugs?Do we have the correct fuel pressure when it wont start?So when it doesnt start it cranks over normal speed etc no signs of battery or alternator not charging issues?
Was this
answer
helpful?
Yes
No
Sunday, August 7th, 2011 AT 12:15 AM
Tiny
LAT
  • MEMBER
Yes have spark to all the plugs and I put a new fuel pump on new filter and new battery. Correct fuel pressure I dont know but with and new fuel pump and filter I would think so if not why. It will start now when it's not hot. But will die after about 1 min.
If I let it cool down till it is cold it will start fine and run good till it gets to op. Temp then it will die agian
Was this
answer
helpful?
Yes
No
Sunday, August 7th, 2011 AT 12:57 AM
Tiny
SATURNTECH9
  • EXPERT
We need to make sure you have the correct fuel pressure when it won't start and run even though you said it has a new fuel we still need to rule that out. Do you have a multimeter to do some testing?
Was this
answer
helpful?
Yes
No
Sunday, August 7th, 2011 AT 1:03 AM
Tiny
SATURNTECH9
  • EXPERT
Another thing we could have is a plugged cat you said it is still sluggish when the car is cool and starts?
Was this
answer
helpful?
Yes
No
Sunday, August 7th, 2011 AT 1:16 AM
Tiny
LAT
  • MEMBER
I do have a multimeter.
Some times it's sluggish when the car is cool,
some times it runs ok for 20/30 min.
Was this
answer
helpful?
Yes
No
Sunday, August 7th, 2011 AT 8:24 AM
Tiny
LAT
  • MEMBER
When this first started I went to the store about 2 milrs from the house came out of store started up fine got to the coner died.
Had it towed home
then started from there
Was this
answer
helpful?
Yes
No
Sunday, August 7th, 2011 AT 8:42 AM
Tiny
SATURNTECH9
  • EXPERT
Have you checked the fuel pressure when it has trouble running?Also it wouldnt be a bad idea when your car is running bad to perform a back pressure test?
Was this
answer
helpful?
Yes
No
Monday, August 8th, 2011 AT 2:22 AM
Tiny
LAT
  • MEMBER
Hey it started this morning when it was not hot checked with timeing light # 1 and # 4 not fireing as much as the rest of them.
New coil on #1 and 4 had the Ignition Module checked on sat. They said it was good going to tell them I want a new one.
Just put a new computer on iton sat. To
Was this
answer
helpful?
Yes
No
Monday, August 8th, 2011 AT 1:32 PM
Tiny
LAT
  • MEMBER
Still no codes from computer
Was this
answer
helpful?
Yes
No
Monday, August 8th, 2011 AT 1:34 PM
Tiny
LAT
  • MEMBER
The only thing I have not done is put new plug wires on
Was this
answer
helpful?
Yes
No
Monday, August 8th, 2011 AT 1:55 PM

Please login or register to post a reply.

Recommended Guides