1961 Mercury Truck hard starting. Wont stay idling

Tiny
KBOUTIN
  • MEMBER
  • 1961 MERCURY TRUCK
  • 60,000 MILES
Hello there.I have a 61 m-f-100. My mechanical fuel pump had been leaking so I went and bought a new one installed it everything happy. Then it started to run like crap.I did not do ne thing else and now it doesnt want to run well.I split the carburator apart cleaed and blew out every orifice I could put it back together samething.I have pulled plug wires off individually to see a decrease in engine rpm. The engine normally doesnt smoke and it started smoking out exhaust and has a really strong odour of fuel almost smells like there is fuel that isnt being burnt. Plz can you help me this is my daily driver!
Do you
have the same problem?
Yes
No
Sunday, October 20th, 2013 AT 3:22 PM

3 Replies

Tiny
HMAC300
  • EXPERT
Well a truck 50 yrs old is probably due for a carb overhaul due to alcohol in todays fuel. You accelerator pump is probably shot and you may have a vacuum leak as well. Also check point nd ignition stuff points must be set to correct gap prior to timing engine.
Was this
answer
helpful?
Yes
No
Monday, October 21st, 2013 AT 7:03 AM
Tiny
KBOUTIN
  • MEMBER
Carburator looks great nothing is overly worn down. Accelerator pump works there is a brand new rotor and points in it. Only thing I havent done is replaced all the spark plugs. Could there be a chance that one of the plugs has fowled?The only thing I touched was the fuel pump due to leaking now all the trouble. Appreciate your response man thanks!
Was this
answer
helpful?
Yes
No
Tuesday, October 22nd, 2013 AT 11:33 AM
Tiny
HMAC300
  • EXPERT
The reason I said carb overhaul is that your pump is probably rubber or leather and alcohol doesn't do those any good but do what you want. Yes you should take the plugs out and clean them and regap them at least to.035" then do a compression check. You may have a bad plug as well and if it's got a pcv which I don't remember that far back check for a clogged pcv if it has the open breather then if you can take it off clean it out. Also check your plug wires although I dont' think that is the problem. They should be 5000 ohms per foot.
Was this
answer
helpful?
Yes
No
Tuesday, October 22nd, 2013 AT 12:34 PM

Please login or register to post a reply.

Related Engine Hard To Start Content

Recommended Guides