Mechanics

CHECK ENGINE LIGHT

2002 Volvo XC70

Engine Mechanical problem
2002 Volvo XC70 6 cyl Four Wheel Drive Automatic 86866 miles

For the last two years (starting at 60000 miles) my check engine light goes on when I go up to the mountains 6500 feet. It was going on when I had the air conditioning on but just the other day it went on with out the air being on.

The Dealer has replace the transmission down to the gas cap. I still have this problem.
Avatar
Donnasando
October 4, 2010.



Check engine light on

Have the computer scanned for code/s-you have a problem within the engine management system that caused the CEL to turn on-This is your starting point of diagnosis, finding out what's going on.

Rasmataz
Oct 4, 2010.
What codes are posting and are they the same codes that keep coming up?

JIS001
Oct 4, 2010.
WAS THE TRANSMISSION REPLACED FOR A CHECK ENGINE LIGHT FAULT OR BECAUSE IT WAS HAVING AN INTERNAL FAILURE? I HAVE SEEN THE BARO SENSOR FAIL AND CAUSE THIS CONDITION, WHAT WERE THE CODES THAT WERE POSTED BEFORE THE FIRST REPAIR AND WHAT ARE THEY NOW?

Tiny
VOLVO SERVICE ADV
Oct 4, 2010.
The transmission was replace due to the check engine light going on. I had other work done prior to that (they changed the soleinoid)These are some of the repair notes: 1/21/10
checked for codes found code ECM-1600 Ecm-170F
replaced faulty boost pressure sensor and reset vehicle
1/05/10 had car towed in New Years day it died going up the mountain.
Technician inspect found charging voltage is low replaced Alternator and reset code
11/20/09
Connected vehicle to VIDA retrieved code ECM-530D
Fault in transmission. Connected vehicle to VIDA retrieved code TCM-0100 control module Fault vehicle drives and shifts normal. Reset all codes code is very intermittent.
10/20/09
connect vehicle to Vida retrieved codes ECM-400C Fault traced found small evap leak. Replaced fuel cap
7/21/09
Connected Vehicle to VIDA retrieved code ECM-530D and TCM-0100 both codes were not current performed software upgrade to ECM
3/12/09
Automatic transmission replaced
9/23/08
Retrieved codes. Faut traced code according to VIDA. TCM software already updated from last repair FOUND FAULTY TRANSMISSION
8/26/08
fault traced found faulty Boost control valve replaced.

This all had to do with the check engine light going on. Note it was almost 6 months and 6000 miles later that I replaced the transmission. I just didn't think that was the problem.

Tiny
Donnasando
Oct 5, 2010.
WHAT DOESNT MAKE SENSE IS WHY THE TRANSMISSION CODES KEEP COMING BACK, EVEN AFTER TRANSMISSION HAS BEEN REPLACED. THE ECM-400C(FUEL TANK SYSTEM LEAKAGE), THERE IS A SOFTWARE UPGRADE THAT MAY BE NEEDED ALONG WITH REPLACING THE FUEL CAP. CODE ECM-530D(SPEED SIGNAL. SIGNAL TOO LOW) MEANS THAT THE SPEED HAS NOT CHANGED OVER A CERTAIN NUMBER OF SECONDS, POSSIBLY RELATED TO A BRAKE CONTROL MODULE. CODE TCM-0100(POOR GEAR SHIFTING QUALITY) MEANS THAT THE QUALITY OF THE GEARSHIFTS IN THE TRANSMISSION ARE TOO LOW, MAYBE A FAILURE INSIDE THE TRANSMISSION. ARE THERE ANY OTHER SYMPTUMS?

Tiny
VOLVO SERVICE ADV
Oct 5, 2010.
Looks like each time the code was for something else. The last visit was for an issue with the MAP sensor which Volvo for some reason likes to call it a " BOOST PRESSURE SENSOR"? What I need to know now is what are the codes that is posting now? Is is the same one for the boost pressure? If it is, did they replace the MAP sensor or the turbo control valve? I have seen people make that mistake a few times. So would it be possible to have it scanned again and can you give me the part # they charged you so I can see if I can verify what part was replaced? If the light only comes on only in high elevations then you could be having an issue with the MAP sensor. But that is only a hunch since I do not now what codes you have stored now?

JIS001
Oct 6, 2010.
In regards to the Boost control valve it was replaced prior to the transmission being replaced: 8/26/08
30670488 Solenoid valve
retrieved codes. Fault traced code according to vida found faulty boost conrol valve replaced.
1/21/10
checked for codes, found code ECM=1600erformance was on the info display ECM-170F test and found faulty boost pressure sensor replaced sensor and reset.
9125462 map sensor.
5/6/10
Low engine performance was on the info display at the time of start up. Inspect vehicle connected to vida no fault codes found. NPO check engine light on road test drove normal np problem
fuel pump replaced.

Tiny
Donnasando
Oct 6, 2010.
So there are no fault codes at this time?

JIS001
Oct 6, 2010.
Not since I last checked But light is on again and I need to take it in
PS Just had engine mount and broken engine pad replaced prior to mountain trip and light going on.

Tiny
Donnasando
Oct 6, 2010.
As soon as you get the codes, please post them on here so I can review them.

JIS001
Oct 6, 2010.
Page 1 of 3