Mechanics

NO SPARK AT PLUGS + NO CHECK ENGINE LIGHT

1990 Toyota Camry

Electrical problem
1990 Toyota Camry 4 cyl Two Wheel Drive Automatic 123000 miles

just bought car on5/9/10, drove it home + noticed slight vibration at idle in gear. Next day changed plugs oil + filter + tranny fluid + flushed engine + rad. + Refilled w/50/50 mix. Tried to start car + wouldn't fire at all. Checked w/timing lite no spark at plugs. Noticed connection at ign mod. Was wet w/ anti freeze, cleaned it w/ brake parts cleaner + blew dry. Hit key + it started but ran very rough while I topped off rad. After 10 min. Gave throttle a little blip + it died immediatly. Has not run yet. I have replaced ign mod w/new one, replaced coil, installed a used dist. W/ the new coil and still no spark. It has always had 12v to coil when ever I check. Tried to pull up any stored codes + check eng light does not work. It does not come on w/ key in on mode, I took dash apart + put in a good bulb from another position + no lite. I checked circuit board at light socket + don't get any voltage there or at plug connecter from green w/ red stripe wire please help. I am willing to pay for solution. Thank you lithorock
Avatar
Lithorock
May 16, 2010.




1990 Toyota Camry no spark at plugs + no check engine light

Check and test the coil, distributor pick-up coil and ignitor.

Tiny
Rasmataz
May 17, 2010.
The items you mentioned were replaced and didn't change anything
AD

Tiny
Lithorock
May 18, 2010.
Check and test the Ne, G, Igt, Igf wiring back to the computer for short and open-if ok, replace the computer.

Tiny
Rasmataz
May 18, 2010.

AD