Mechanics

JUST CUTTING OFF WHILE DRIVING - THOUGHTS?

Oldsmobile Other

Ok, some background on this car.

1991 Oldsmobile Cutlass Supreme. 6 cyl. Enngine. It's got about 154k miles. This was my fathers car he bought brand new in 1991 and handed down to me recently. YAY. Right? My Uncle worked at a Dealership so every OUNCE of work was performed from an Olds dealer on it. I realize that doesn't negate any issues from arising, but it's been babied. Honestly, and maybe that helps the diagnosis a LITTLE.

Driving down the road at about 45mph on Sunday and the car just died. All lights on the dash were on when I looked down as if I turned the key forward without starting the car. I popped it in Neutral and started it and put it back in gear and off I went.

Then it did it a couple more times at 30 - 50 mph. Never at a stop, although it's increasingly idled 'rougher' than I think it should.

So after several times of this happening on Sunday I finally got her home. I parked it for a bit, and went inside, came back out and it would NOT start. Turned over fine, just wouldn't start. Finally it would start, but died right out again. After fiddling trying to start it, I finally got it started and thinking maybe some really bad gas was the culprit. I put HEET in it (I know I know). Ran like a champ again. I ran the gas down till 2 light bars were left.

Today I got gas from a different gas station and put STP gas treatment in it (I know I know). Got on the Interstate and on the same ramp (coincidence I'm sure) it died out on me again. Same thing. Started right back, and didn't do it again all the way home this time.

I was thinking fuel filter or maybe fuel pump? Talked to my Dad and he said he had the fuel filter replaced a few times through normal routine maintenence on this car and suggested this site in particular : )

He was RELIGOUS about the maintenance on this vehicle, he really was! I know alot of times people don't do something until it ABSOLUTELY NEEDS it, and he was the complete opposite with his olds. He did it by the dealers recommendations because his brother was the foreman at the dealer.

Wish he still worked there : (

Any thoughts would be appreciated! Sorry about the book!
Avatar
Itllbeok
April 10, 2007.



I experienced a similiar situation. I was on a three-lane highway, my car just died while I was on the mid-lane. Thank God that vehicle behind me was paying attention. I just let it role to a slower pace, stopped the car, put it in park, and started right up. The oil light came on, I assumed the worst situation. I took the nearest exist and pulled into a gas station. I checked the oil level, transmission level, and the radiator fluid. They were fine, I did notice that the engine would seem to loss power, but then rev itself back up.
I then assumed maybe the oil pump was going out. I took it a parts store and they plugged in their scan tool. The problem wasn't the oil pump, the MAF Sensor was defective. This MAY be the problem your having.

Tiny
Yeshayahu
May 1, 2007.
I had the same problem on my 1988 3.8L Cutlass Ceirra a few years ago. Drove me crazy! Engine would just cut off. Sometimes wouldn't start. Sometimes would just cut out for a few seconds and then continue on.

In the end it turned out to be the crank sensor a small (and cheap!) Device that senses the engine rotation.

Also found out when it did stall, I could go out and wack it lightly and it would start working again. So if you are still trying to debug, you might try this.

Tiny
Burhop
May 19, 2007.
Another possibility if it has fuel injection is the
fuel pressure regulator. Sounds alot like the problem
I recently had with a Jeep.

Tiny
Samuelje93
Jun 3, 2007.