Mechanics

A/C NOT WORKING

2005 Kia Spectra

Air Conditioning problem
2005 Kia Spectra 4 cyl Two Wheel Drive Manual 78000 miles

I have a problem with my A/C, The A/C compressor is not getting voltage. When I select the switch for A/C the compressor will not turn on. I know the air duct door is working correctly to choose heat or cold.I have checked with a multimeter for power at the compresser, one lead on ground and the other on the plug, I have checked the triple pressure switch and am not getting power to either of them with A/C selected. I know I have freon in the system. The A/C belt is tight and in good condition. I have checked all the a/c fuses. I have checked the A/C relays and swapped them with same relays. When I jump the A/C control relay with a jumper wire the compressor turns on and the a/c blows cold.I checked for voltage at the A/C control relay and at 85 and 30 terminals there is voltage. Terminal 86 and 87 does not have voltage. It seems like the relay is not getting a power signal when the A/C button is pressed/turned on. Do you think the A/C control switch assembly is bad? On the control switch when you select A/C the button still lights up as if it were working. What are other possible causes of the A/C not working.
Avatar
Brandon24
January 18, 2010.




On many systems, the compressor will not turn on if the refrigerant is low because the " low pressure safety switch" prevents the compressor clutch from engaging if system pressure is low. This protects the compressor from possible damage caused by a lack of lubrication.

One of the first things you should check, therefore, is compressor engagement. If the compressors magnetic clutch is not engaging when the A/C is turned on, the problem may be a blown fuse or a wiring problem. If the fuse is blown, replacing it may restore cooling temporarily. But the underlying reason for the fuse blowing in the first place needs to be identified and corrected to prevent the same thing from happening again.

If the magnetic clutch is receiving voltage but is not engaging the compressor, the clutch is defective and needs to be replaced. If there is any evidence of leakage around the compressor shaft seal, the seal should also be replaced.

If the clutch works but fails to turn the compressor (the belt may squeal in protest!), The compressor has seized and needs to be replaced.

Compressor failures are usually the result of loss of lubrication, which in turn may be due to low refrigerant in the system, a blockage (such as a plugged orifice tube which prevents refrigerant and oil from circulating to the compressor), loss of lubricant due to leaks or improper service procedures (not adding oil to the system to compensate for oil lost through leakage or component replacement), or use of the wrong type of lubricant.

R-12 systems require mineral oil while R-134a systems require various types of PAG oil or POE oil. Using mineral oil in a newer R-134a system can cause serious lubrication problems as can using the wrong grade (viscosity) of PAG oil. Always follow the vehicle or lubricant manufacturers compressor oil recommendations.

The next thing you should check when troubleshooting a no cooling problem is system pressure. For this, you need a set of A/C service gauges. Attach your service gauges to the high and low service fittings. If both the high and low side pressure gauges read low, the system is low and needs recharging. But before any refrigerant is added, check for leaks to find out where the refrigerant is going.

Tiny
Rasmataz
Jan 18, 2010.


AD