Mechanics

COUGAR HIGH IDLE

1992 Ford F-250

Hi. I've had a '92 Mercury Cougar for a few months (145,000 mi), and it always seemed to idle a bit high. Last week it seemed to get much worse, and it now idles very high, at 2500 RPM in Park and 1200 RPM in Drive with brakes on. I can drive 35-40 mph without giving gas. My mechanic checked thoroughly for vacuum leaks (lowered rpm for testing in some nifty way and carefully checked everywhere, including removing to intake manifold to check the gasket. No leak found. Sensors all test OK. Codes not showing anything (though Check Engine has come on then off a few times). The injectors, however, are showing very high voltage, so he thought brain box must be faulty. I got another for $30 from the junkyard: no change. Of course it's possible that the " new" one is bad in the exact same way... I don't want to drive it much, because it's bad on gas, it's stressing my brakes out and I heard it could blow a head gasket, never a strong point on these cars (Ford 3.8 V6) anyway. Can anyone help? Thanks.
Avatar
Mzannoni
January 13, 2007.



Thank you for the donation.

Has the iac motor and egr valve been cleaned?

Is the accelerator pedal stiff at all?

Thanks. The iac motor was temporarily replaced for diagnostics: no change. How do you clean the egr valve? (And wouldn't that show up on the scan?)

Pedal not stiff, even worked the other ond of the cable to make sure it " bottoms out" in the resting position...

Mike

Tiny
Mzannoni
Jan 13, 2007.
It may show up, I'm not familiar with OBD1. OBD 2 would.

Try this first: Disconnect your iac motor harness, does it the idle drop? Check your throttle position sensor. The computer can be reading that the throttle was slightly open. So it sends the command for more fuel, and the IAC compensates by opening more.

Before you pull the egr valve, get a gasket. I use a intake cleaning spray, anywhere you see carbon, clean it off, The ports for the egr passageways should be cleaned. A pipe comes in handy for this. Make sure the pintle moves and is clean.

I have this identical problem. Did you ever figure out how to fix it? I changed the throttle position sensor and it didn't change anything.

Tiny
Kkm5758
Jun 18, 2012.
Kkm, did you perform the other diagnostic steps outlined, such as cleaning the IAC and EGR?

Rivermikerat
Jul 20, 2012.