Mechanics

4WD PROBLEMS

2004 GMC Sierra • V8 4WD Automatic • 120 miles

My Sierra 2500 has the push button 4wd selector to the left of the steering wheel. For the past several months, when I start the truck the 4wd indicator lights are illumninated randomly in the AWD, 2wd, 4wd high and 4wd low positions. The truck usually is in 2wd even when the 4wd is indicated, but not always. Just recently, none of the lights are illuminated, and the truck is in 2wd. The service "4wd message" shows up in the information center. Sounds like a bad switch/indicator, right? Has anyone had experience with this problem?
Avatar
Papanicko
January 3, 2011.




Switch is to be suspected
should have it checked for codes
as encoder motor is a common failure with a similar symptoms
AD

BMRFIXIT
Jan 4, 2011.
I was hoping for a little more insight than just "check the codes". The codes can be very misleading, not to mention expensive to get from the dealer. Is there no other test to isolate the problem between the switch (which now is illuminated again) and the encoder? What about a software update? Pulling out the TCCM fuse? Is "check the code" the best you can do?

Tiny
Papanicko
Jan 4, 2011.
I have a 2006 Sierra 1500 Z71 and my push button 4WD was acting up and it always said service 4WD. So I just replaced the switch and now its working great. It cost me about $90.00.

Tiny
Hunter
Jan 10, 2011.
This problem turned out to be the encoder ring, not the switch and not the encoder motor. Pretty easy to change out, with good instructions on the web.

Tiny
Papanicko
Jan 11, 2011.

AD