Mechanics

INTERMITTANT BLOWER PROBLEM NOW NOT WORKING AT ALL, THE RADIO NOW TOO.

1997 Buick Lesabre • 195,000 miles

Im trying to help a struggling single mom with her car. It has the manual heat and a/c controls. At first her blower motor would stop for a few days, then come back on. She said it came on at times when she'd hit a bad bump. I've read of a worn motor working intermittently like that, but I checked at the connector and there's just no power going to the motor. A couple times I replaced both relays, each at different times (one is for the high speed and the other in general), and both times it made the blower work, but eventually it would stop again. This is over the past year. Replaced the resistor too cuz I didn't know how to test it. A week ago now her radio also went out. (And perhaps unrelated but she's has an intermittent starting problem cuz of the passkey/security light thing.) I'm wondering if the ignition switch could be bad, seeing as how its normal function is to momentarily turn off the radio and blower and such when turning the key (the key switch itself was replaced a couple years ago when it wouldn't start due to those two thin white wires running to the anti-theft setup). Please help. It's hot here in the South and single moms have such a heavy burden as it is.
Avatar
Brotherjimintn
June 14, 2012.



This kind of sounds lieka ground problem like one that is loose. The ground to this is on the right front of engine compartment for teh blower and the left kick panel for the control unit. Check both of those. The ground for the radio is on the left kick panel as well so check that one first.

Hmac300
Jun 14, 2012.