Mechanics

I SEEM TO HAVE SOME TYPE OF VACUUM OR INTAKE LEAK THAT SOUNDS LIKE IT IS COMING FROM THE FIREWALL. PLUGS ARE BURNING HOT & ALSO CAN'T SEEM TO FIGURE OUT THE HOSE ROUTING AND SENSOR(?)ON THE AIR FILTER BOX. ANY IDEAS? 2.5V6. THANKS!

1995 Mazda Millenia

I recently replaced the engine with a 40,000mi 2.5 that seems to have no issues(actually runs like a sewing machine!). Never could locate the plug for the sensor(?) On the airbox or the correct location for the lines that come from it. Now when motor is up to temp it seems to idle erratically. I stopped driving it for fear of the unknown if you will! Any thoughts on this would be greatly appreciated!
Avatar
Metalpoison
December 14, 2011.




Inspect and test the IACV, EGR valve and test the TPS sensor to include a fuel pressure check
AD


Rasmataz
Dec 14, 2011.
Here is a schematic of the vacuum system. It's for the 2.5L. Let me know if it helps.

Joe


Thanks for the schematic! It was extremely helpful! One of the vacuum valves on the air box is not connected. Also having trouble locating the electrical connector for it. Could this possibly be the problem? I will be setting up a paypal account to give a donation & will definitely share your site with others!


Tiny
Metalpoison
Dec 15, 2011.
You are very welcome for the schematic. And, yes, that can be the problem. Let me know if it helps.

If you can donate, great. If you can't, maybe next time. Regardless, your positive feedback is appreciated. Tell as many people as you can.

Take care and if we don't speak before, have a good Christmas.

Joe



AD