Mechanics

FORD F-150 WATER PUMP PROBLEM

1993 Ford F-150 • 180,000 miles

I have a 93 f150 xlt 4wd. Got a new water pump put in and thermostat and radiator. Upper and lower rad hoses. Got extreme vibration when I put the truck in gear. Slipping tranny. Power loss. Overheating on motor. But the gauge in the truck is normal. And the and the upper rad hose is expanded like itz going to bust. Foreseeing antifreeze back up threw rad cap and resavore other than flowing threw engine. Never had any problems b4 new parts. Any ideas?
Avatar
Raw1
October 21, 2012.




Why did you do this repair? It sounds like you have lost head gaskets. Did it overheat before?

The trans sounds like slipping. Check the fluid level, beyond that, you need a trans shop to road test and verify

Roy

ASEMaster6371
Oct 21, 2012.
Water pump was leaking. When friend was taking off fan he busted a small hole in radiator. That's why that was changed. Changed thermo when changed water pump. Tranny is fine never slipped b4 work was done goes ryt in gear the vibration of the engineis the main prob. Never overheated b4 only reason for repair is bc water pump was leaking. Was getting it ready for winter
AD

Tiny
Raw1
Oct 21, 2012.
Its a 302- 5.0 automatic. Tranny goes in gear. Just stutters engine is shaking badly. Fires ryt up vibrates bad. Wen u push throttle down just a little bit shakeing gets worse. And heats up reel fast but the gauge in the cab is normal. Rad gets real hot and the upper rad hose seems like itz going to bust cant even squeeze it fully expanded and hot reel fast within 3 or 4 min

Tiny
Raw1
Oct 21, 2012.
Was not overheating. Just wanted to stop antifreeze from dripping the gasket was bad original 93 pump. Figured it be better to just change it other than just replace gasket.

Tiny
Raw1
Oct 21, 2012.

AD