Mechanics

IGNITION LIGHTS

1992 Volvo 940 • 103,000 miles

I have a Volvo 940 1992, the problem is the ignition lights do not always come on. When I insert the key and turn it nothing but the seatbelt warning light comes on in the dash. The car starts OK and after driving it for maybe twenty minutes and test it, the lights usually come on. Also, sometimes the lights come on at startup, but after a while when I pull on the handbrake, nothing. This all started one year when the battery went flat, I removed the battery and charged it up, ten minutes after starting the car the handbrake light came on (the car was stationary) all worked ok until again last winter then battery died. In May this year the car started no bother, I drove to the petrol station, filled up then tried to start but no joy, the battery was totally flat. This happen yesterday on the motorway, it just stopped dead, again battery was dead. I found a few wires coming from the positive battery terminal with two fuses on them, I replaced these and the connectors as they were badly weathered, the ignition lights all came on again, but today the lights are off again.
When driving, if the ignition lights are not functioning, the wipers are slow and the electric windows are slow. I have switched on the headlights and rev'd the engine, the lights remain steady, someone told me that if they dipped and rose then it meant the battery was not charging. I totally baffled, any help would be good.


Avatar
Flightsimer
August 25, 2011.



Suspect faulty ignition switch. Does charge light come on with key in on position? What happens if key is wiggled? Also have ALTERNATOR tested

Docfixit
Aug 25, 2011.
When the lights all work, no the battery charge light does not come on when driving, just when I turn on the ignition and start the engine, once started, all lights turn off as normal.

Tiny
Flightsimer
Aug 25, 2011.
Have ALT tested

Docfixit
Aug 25, 2011.
OK I went out tonight and tried again, no lights, so I wiggled the ignition key, no luck there, so I gave the plastic cover that goes over the steering column a bang, sll lights came on. So I took the plastic cover off and checked, pulled, banged all the wires, wiggled the ignition switch but the lights all stayed on as normal. Turned the car engine off completely, switched on, all lights are on, replaced cover and banged it many times, the lights remain on. So I took her out for a spin and all is fine again. Don't know now what else it could be, the battery is charged up again so does that mean the alt is OK?

Tiny
Flightsimer
Aug 25, 2011.
Ignition switch faulty and when it acts up the ALT does not charge. Banging on collumn confirms open in switch contacts

Docfixit
Aug 25, 2011.
Ok so do I just replace the Ignition switch?

Tiny
Flightsimer
Aug 25, 2011.
That's what I would do or live with it

Docfixit
Aug 26, 2011.
Found one on ebay, new £24

Tiny
Flightsimer
Aug 26, 2011.
Good keep me posted
Thanks

Docfixit
Aug 26, 2011.
Will do, it should be here on Monday.

Tiny
Flightsimer
Aug 27, 2011.
Page 1 of 2