Wipers stay on with key out

Tiny
GOBBY1
  • MEMBER
  • 2007 CHEVROLET TAHOE
  • 5.3L
  • V8
  • 2WD
  • AUTOMATIC
  • 86,000 MILES
The wipers wont shut off unless the fuse is pulled,
the vehicle does not have the heater washer option.
replacing the motot/module assy changes nothing,
unplugging the multi function switch changes nothing,
unplugging the bcm changes nothing,
checked the plug and ground at motor and ran jumper per bulletin, no change,
no relay located in fuse block or in dash for wiper motor.
no dtc on system scan
bcm scan shows park request and it does not park just keeps running

any ideas
Do you
have the same problem?
Yes
No
Saturday, May 3rd, 2014 AT 7:25 AM

10 Replies

Tiny
HMAC300
  • EXPERT
The circuit board on wiper motor may be bad or the wiper motor itself. If may also be this tsb problem with bcm.
Condition/Concern:

Some owners may comment on any of the following concerns: high speed wipers inoperative, power door locks/windows inoperative, radio does not turn off when driver's door is opened, dome lamps are always on, door ajar message is always on the DIC, hazard flashers stay on or won't turn on, front fog lamps inoperative, high/low beam select switch inoperative, "tow haul" telltale always illuminated or won't illuminate, and/or the headlights will not turn on or off when requested by the manual headlamp switch. These concerns may be due to internal BCM damage. The damage to the BCM may have been caused by an electrical spike from the wiper system when the wiper motor is turned off.
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 8:51 AM
Tiny
GOBBY1
  • MEMBER
No other option is effected, and the controller is part of the motor assy and it was replaced, also ran redundant ground per bulletin.
And with the bcm and or multi function switch it still does not turn off
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 9:04 AM
Tiny
HMAC300
  • EXPERT
Guess it would be the motor then as it has power to it all the time either that or it's an issue with the multi function switch grounding all the time. That would be the only thing I could think of. There used to be circuit boards for park in the older motors but im not sure if they still have those or are controlled by bcm and the only other thing I can think of would be one of the wiper relay s are stuck. Those are underhood I would think they would be warm or hot after truck is off.
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 9:12 AM
Tiny
GOBBY1
  • MEMBER
The motor assy ( module included) was replaced and it changed nothing
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 10:58 AM
Tiny
HMAC300
  • EXPERT
The only thing I can think of are something wrong with the bcm even if it shows park on the scanner or a bad ground-lh rear of engine and front of dash by motor. Or one of the two relays still supplied power to the motor when it should be off. They are underhood for that though. If this is /was a donation question get back to me and i'll se your get a refund. However they may have someone else try to help you first.
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 11:07 AM
Tiny
GOBBY1
  • MEMBER
They will stay on even if the bcm is unplugged.
No pcb or wiper relay found. In dash, in fuse block or elsewhere.
Unless it is part of the lower ubec and not serviceable they are not to be found.
Also in si ( gm web) and all data the 2006 and 2008 show relays the 2007 does not, but, it shows on a circuit diagram with no circuit number other than between motor and fuse block in the electrical path
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 12:56 PM
Tiny
HMAC300
  • EXPERT
I dont' want to soubt you on the wiper relay but this in our manual for 07/08/09 see pic. Anyhow I have no further suggestions.
Was this
answer
helpful?
Yes
No
Saturday, May 3rd, 2014 AT 3:35 PM
Tiny
GOBBY1
  • MEMBER
I appreciate your help. But the fuse block does not have any relays labeleld pcb, nor wiper, nor wiper1 or 2
the fuse block lookd like the one shown for a 2008 in all data.
Was this
answer
helpful?
Yes
No
Monday, May 5th, 2014 AT 5:12 AM
Tiny
HMAC300
  • EXPERT
Looking at the 08 fuse panel which we don't have a pic of, there are wiper relays but are part of the fuse block and not serviceable so that may be your problem but I don't wan tto say for sure. These are printed circuit board relays. If you have used the fuse from harbor freight it' s possible that they have burnt the circuit broad up because they do not blow like they are supposed to. If you have any of these in your vehicles remove them immediately. They will have no numbers on top of fuse so easy to id. I have no further suggestions sorry.
Was this
answer
helpful?
Yes
No
Monday, May 5th, 2014 AT 6:43 AM
Tiny
JENNIFER CLARK BROWN
  • MEMBER
I am having the same problem, did you ever figure out a solution?
Was this
answer
helpful?
Yes
No
Sunday, December 4th, 2016 AT 7:38 PM

Please login or register to post a reply.

Recommended Guides