Wind shield wiper sprayer not working properly

Tiny
EL REY CHAMP BECERRA
  • MEMBER
  • 2002 CHEVROLET CAPRICE
  • 5.0L
  • V8
  • 4WD
  • AUTOMATIC
  • 100,000 MILES
I changed out the pumps for the windshield wiper fluid, cleaned the hoses and nozzles. Now the problem is it only sprays fluid when the cars in (P) Park! Does not spray while driving, even if I'm at a stop it wont spray unless it's in Park? I'm so confused I have not idea on what to do. Please help!
2002 Suburban

Thank you!
Do you
have the same problem?
Yes
No
Saturday, October 17th, 2020 AT 7:07 AM

6 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

That is an interesting one. The only thing that could even be remotely possible is if the wiring you disconnected somehow was damaged, and that is a long shot.

You listed this as a Chevrolet Caprice and in your post said it's a suburban. I'm looking at suburban schematics. I guess the first thing to check (if you replaced both pumps) is to make sure the two wires to the pumps weren't switched.

I attached two pics below. The red wire is for the front pump and the green is for the rear.

Confirm they are positioned correctly.

Let me know,
Joe
Was this
answer
helpful?
Yes
No
+1
Saturday, October 17th, 2020 AT 8:28 PM
Tiny
EL REY CHAMP BECERRA
  • MEMBER
It's a 2002 Suburban and the pumps are just plug in? I'm not understanding what could be switched?
Was this
answer
helpful?
Yes
No
Sunday, October 18th, 2020 AT 6:56 AM
Tiny
EL REY CHAMP BECERRA
  • MEMBER
And where do I check for the switched wires? Thank you so much!
Was this
answer
helpful?
Yes
No
Sunday, October 18th, 2020 AT 6:58 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

There should be two plugs. I believe they are of the same design.

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Sunday, October 18th, 2020 AT 8:25 PM
Tiny
EL REY CHAMP BECERRA
  • MEMBER
On the pumps? One is a little bigger the other.
Was this
answer
helpful?
Yes
No
Monday, October 19th, 2020 AT 4:51 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Okay, I'm looking at a schematic and only see the wiring.

This is really odd. Do me a favor. Have a helper place the vehicle in drive while you open the hood to see if there is power to the pumps. This honestly doesn't make sense.

Let me know.
Joe
Was this
answer
helpful?
Yes
No
Monday, October 19th, 2020 AT 6:16 PM

Please login or register to post a reply.

Sponsored links