Will only reverse after repair

Tiny
SAILORSMITTY
  • MEMBER
  • 2000 GMC JIMMY
  • 4.7L
  • V6
  • 2WD
  • AUTOMATIC
  • 182,000 MILES
I had a 1860 code for the solenoid. I replaced the wiring harness and TCC solenoid. The car will only go in reverse an neutral. I have enough fluid. The other solenoids worked fine before, as far as I know. This repair cleared the check engine light and it's not throwing another light for the other solenoids. I do not know what else you check. The only issue before repair was that code. Could I have mis-aligned that piston or gear when putting the valve body back on?
Do you
have the same problem?
Yes
No
Sunday, December 1st, 2019 AT 12:53 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

For any reason, did you have the pressure control solenoid out? See pic 1. Also, if you place the transmission in first or second gear, does it engage? When you reinstalled the components, did everything go together easily?

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2019 AT 8:44 PM
Tiny
SAILORSMITTY
  • MEMBER
Hey. Thanks so much for responding. I actually just didn't have the pin set quite properly into that piston when I reinstalled the valve body. I pulled it off and re-installed valve body and it runs fine now. Well, check engine light now codes a solenoid a code. I should have replaced them all but only had the original code so just did TCC.I'll be replacing the rest next week. Lol.
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2019 AT 9:35 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Glad you got it fixed. That is an easy thing to have happen. If you give me the code, I can point you in the right directions as to which one is of concern. Also, if you need directions, let me know that too.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Tuesday, December 3rd, 2019 AT 5:33 PM

Please login or register to post a reply.

Sponsored links