1997 Vauxhall Tigra Speedometer not working, engine light c

Tiny
TYNE-E
  • MEMBER
  • 1997 VAUXHALL TIGRA
  • 4 CYL
  • 2WD
  • MANUAL
  • 72,000 MILES
Hi,

I have a 1997 vauxhall tigra we brought it a few years back have had a few things go wrong but generally ok.

I was driving it the other day when I noticed that the speedometer wasn't working! I drove it for a few miles and then had to stop at traffic lights, when I stopped the engine management light came on and then the car cut out.

The car started again straight away, but the same thing happen a few more miles down the road.

Can you please tell me if the speedometer not working and the engine light coming on (and making car cut out) are part of the same problem and if so any ideas what the problem may be?
Do you
have the same problem?
Yes
No
Thursday, March 19th, 2009 AT 9:34 AM

4 Replies

Tiny
DAVE H
  • EXPERT
Hello .. thanks for the donation .. much appreciated

The cutting out and the speedo may/may not be related ? first thing you need to do is have the cars computer read for fault's .. when engine managemant light comes on it stores a fault code in the PCM (computer) this will tell us in what system the fault lies .. most good repair centre's now do diagnostic scanning ... also does the light stay on .. or go off again ? does the car run OK apart from the cutting out ..in the interim before testing for codes .. remove and clean the CKP (crankshaft position sensor) I do not have any diagram's for this vehicle as it was not released in the USA .. but your local library or autoparts store should be able to supply a repair manual for step by step instructions and diagrams ... hope this helps ...

let me know !


http://www.2carpros.com/forum/automotive_pictures/266999_AAA2_308.png

Was this
answer
helpful?
Yes
No
Thursday, March 19th, 2009 AT 10:31 AM
Tiny
TYNE-E
  • MEMBER
Hi ya,

Thanks for your reply, the light comes on and then the car cuts out once you restart the engine the light goes off. The light generally comes on when you are slowing down.

The Car runs fine apart from this the engine sounds fine.
Was this
answer
helpful?
Yes
No
Thursday, March 19th, 2009 AT 11:02 AM
Tiny
DAVE H
  • EXPERT
Hello.

This does sound like it could be the CKP sensor... a common fault on the vauxhall range ! so I would remove and clean it or replace it !! .. but I would still have the cars computer read for fault codes as well ... to rule out anything else ... i'm not sure on your year of tigra if it has a cable for speedometre function or a VSS (vehicle speed sensor) .. It is posssible if it is a VSS then it's tied into the cutting out ? if you get a repair manual and let me know we can assist further ... hope this helps

let me know !


http://www.2carpros.com/forum/automotive_pictures/266999_smiley5_6.png

Was this
answer
helpful?
Yes
No
Thursday, March 19th, 2009 AT 11:27 AM
Tiny
TYNE-E
  • MEMBER
Thank you I'll let know how I get on
Was this
answer
helpful?
Yes
No
Thursday, March 19th, 2009 AT 11:37 AM

Please login or register to post a reply.

Recommended Guides