Transmission Malfunction 2009 Ford Focus LX Sedan

Tiny
MAND76
  • 2009 FORD FOCUS
  • 2.0L
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 140,212 MILES

Drove through deep water (stupid yes). It will not start, day one the warning message 'Engine Malfunction'. Day two it's making a ticking over sound and now the warning light is saying 'Transmission Malfunction'. Now today, its ticking over making no noise all the warning lights are on, however the battery light is the last one to light up. I am hoping and praying that its not as bad as im thinking it is. I should mention that not long after the car we did have trouble with the transmission. It wouldn't move out of the P position. SO we have since been using my key to release it from Park, so whether the two are linked im not sure. Is there anything I can do to rule out that the engine has packed up? If its not the engine, well then hopefully it won't be to big a problem to fix fingers crossed. Thank you so much please give me good news fingers crossed.

Amanda

Do you
have the same problem?
Yes
No
Monday, May 5th, 2014 AT 10:36 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,399 POSTS

How deep was the water? Will the engine turn at all?

Was this
answer
helpful?
Yes
No
Tuesday, May 6th, 2014 AT 5:09 AM
Tiny
MAND76
  • MEMBER

Engine wont turn making clicking noise. My partner took Battery to be checked no problems there. No power to the Alternator. So give me the good news

Was this
answer
helpful?
Yes
No
Tuesday, May 6th, 2014 AT 7:28 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,399 POSTS

See if you can turn the engine by hand at the crank pulley. Also, how deep was the water?

Was this
answer
helpful?
Yes
No
Tuesday, May 6th, 2014 AT 11:04 AM

Please login or register to post a reply.

Other Transmission Interchange Questions