Idle Air Control

Tiny
TOY TACOMA
  • MEMBER
  • TOYOTA PICKUP
I have a 1995 Toy Tacoma 4x4, 4cyl, 2.7 l with 222,000 miles.
Recently, at morning start, the idle (which is normally a bit higher at start for a few seconds, then drops to normal idle) surges a bit at the time it usually drops, then drops to normal. It only does this on a cold start, idles like it always has once it goes through this new thing it's doing. I asked a mechanic and he said it sounded like I need to have the Idle Air Control Motor replaced. True? I use complete fuel system cleaner every 6 months and do not have a check engine light at this time. I do have to have the throttle body cleaned about every 2 years when the gas pedal begins to stick a bit but I had that cleaned at 208,000. Last fuel system cleaner added July 2007 at 217,000 miles. I, myself, replaced the MAF in July - been running great until this new thing started this fall.
Any suggestions?
Do you
have the same problem?
Yes
No
Monday, November 12th, 2007 AT 5:44 PM

2 Replies

Tiny
FISHERMAN
  • MEMBER
Your mechanic could be right.
Check the IAC I ll be back with the location on your truck.

Good Luck!
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2007 AT 8:17 PM
Tiny
FISHERMAN
  • MEMBER
Here you have how to test the IAC Valve:


http://www.2carpros.com/forum/automotive_pictures/576_IAC_Toyota_Tacoma_1.jpg



specifications:


http://www.2carpros.com/forum/automotive_pictures/576_IAC_Toyota_Tacoma1_1.jpg

Was this
answer
helpful?
Yes
No
+1
Monday, November 12th, 2007 AT 8:29 PM

Please login or register to post a reply.

Recommended Guides