ALTERNATOR OR BATTERY?

  • Tiny
  • Dspath25
  • TOYOTA

Occasionally, when I turn the key, my car won't make any sound, but all the lights will come on. Othertimes, my car will make a grinding sound, but the engine won't start. The rest of the time it will start just fine. My oil light always stays on for ten seconds or so after starting.

Do you
have the same problem?
Yes
No
Monday, December 18th, 2006 AT 2:22 PM

4 Replies

  • Tiny
  • Backyardmechanic
  • MEMBER

I don't think it's the alternator or battery that is your problem. If it was the alternator or battery it would probably happen all the time. Try and check the connections at the battery. Make sure they are tight and clean. Hope this helps :D Backyardmechanic

Was this
answer
helpful?
Yes
No
Monday, December 18th, 2006 AT 2:55 PM
  • Tiny
  • Dspath25
  • MEMBER

Btw, sorry I didnt give the info earlier.

Toyota camry 90 deluxe 4 dr, 4 cyl, 1500000 miles, auto trans.

A little more detail to the question: when I start my car and it makes the grinding sound, it sounds as though the starters is stripping the flywheel, or just slipping, but it makes a whirring/grinding sound and my engine does not turn over?
Plz help

Was this
answer
helpful?
Yes
No
Monday, December 18th, 2006 AT 8:44 PM
  • Tiny
  • Backyardmechanic
  • MEMBER

Does the noise happen all the time or only when it won't start If the noise only happens when the car won't star then you are back to the cable connections. If it happens every time you start the car then there is a problem with the starter or the flywheel is missing teeth.

Was this
answer
helpful?
Yes
No
Tuesday, December 19th, 2006 AT 7:08 AM
  • Tiny
  • Captain Hank
  • MEMBER

With the amount of miles on your car I agree with the last answer. Check your starter and flywheel first. Either one/or both of these could be the culprit.

Was this
answer
helpful?
Yes
No
Sunday, December 24th, 2006 AT 12:27 AM

Please login or register to post a reply.

Other Alternator Grind Questions