1996 Other Toyota Models Running rich

Tiny
DEAONI
  • MEMBER
  • 1996 TOYOTA
  • 6 CYL
  • 4WD
  • MANUAL
  • 25,000 MILES
Hello I have a 1996 Toyota T-100 V-6 3.4l engine.
I just had a new mass air flow meter installed and just had new head gasket installed, new pcv valve new spark plugs and new coils and plug wires. While doing a compression check I notices that number two cylinder was leaking gas. Check all the injector and they tested good on the ohm reading. Can you tell me what else to check on?
Thank you
Albert
Do you
have the same problem?
Yes
No
Sunday, February 3rd, 2008 AT 4:02 AM

13 Replies

Tiny
MERLIN2021
  • EXPERT
Check the fuel pressure, could be a bad pressure regulator, or clogged return line.
Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2008 AT 6:40 AM
Tiny
DEAONI
  • MEMBER
Hello I have a 1996 Toyota T-100 V-6 3.4l engine.
I just had a new mass air flow meter installed and just had new head gasket installed, new pcv valve new spark plugs and new coils and plug wires. While doing a compression check I notices that number two cylinder was leaking gas. Check all the injector and they tested good on the ohm reading. Can you tell me what else to check on?

. Fuel pressure is 40 psi
2 Fuel pressure regulator works and return line clear no blockage.I

After engine runs for about 4-5 minutes is starts to have a rich smokey fuel smell exhaust to it.

The cyclinder pressure is 175 psi across all 6 cylinder.

How could I check the connector on the fuel injector side?
While doing the Cylinder psi I noticed that number two cylinder leakes fuel (lots). I replaced that fuel injector after I did the head job.

What else could I check and do?

Thank you :x
Albert

:lol:
Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2008 AT 3:23 PM
Tiny
MERLIN2021
  • EXPERT
Is fuel spraying out past the O ring? It may have been cut during the install, check the ECT, if it's NG you might be staying in open loop. Very rich this way.
Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2008 AT 7:07 PM
Tiny
DEAONI
  • MEMBER
No its not leaking out from the o-rings its spraying into the cylinder.
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2008 AT 12:41 AM
Tiny
MERLIN2021
  • EXPERT
Have you check both the injector and the harness? Is it getting constant or pulsing power? If power is constant, check wiring, if pulse test, replace the injector.
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2008 AT 2:34 PM
Tiny
DEAONI
  • MEMBER
Only checked the injectors all 6 Injector are 14 ohms the book calls for between 12-16ohms. How do you check the harness? How can you tell if its constants or pulsing power? And how do you check for it?

Thank you
Albert
Was this
answer
helpful?
Yes
No
Tuesday, February 5th, 2008 AT 12:32 AM
Tiny
MERLIN2021
  • EXPERT
They make small lights that plug into the injiector harness, calld noid lights, grab some and plud them in, it will show you if its constant, or pulsed.
Was this
answer
helpful?
Yes
No
Tuesday, February 5th, 2008 AT 8:24 AM
Tiny
DEAONI
  • MEMBER
L'll check the local auto store here if they have any. Thank you
Albert
Was this
answer
helpful?
Yes
No
Tuesday, February 5th, 2008 AT 12:27 PM
Tiny
DEAONI
  • MEMBER
Hello just came back from Hawaii and got a noid light set from Kragen auto. For $36.00.

Tested all 6 injectors harness. All but one are pulsating # 2 injector stays on constantly.

Where and what should I check next?

Thank
Albert
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 12:55 AM
Tiny
MERLIN2021
  • EXPERT
There are two ways injectors are powerd, power always on, pulsed by neg(-) or pulsed by pos(+)...I believe yours is controlled by the ground, Trace the White wire of the #2 injector, run a continuity test to the block, if no cont, trace wire for a break....


http://www.2carpros.com/forum/automotive_pictures/62217_Diag7_1.jpg

Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 7:54 AM
Tiny
DEAONI
  • MEMBER
Thanks will try it today.
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 2:06 PM
Tiny
DEAONI
  • MEMBER
Checked # 2 injector wires white and black/red from connector to ecm and has continuity on both wire.

So could it be the ecm?

Thanks
Albert
Was this
answer
helpful?
Yes
No
Monday, February 25th, 2008 AT 12:47 AM
Tiny
MERLIN2021
  • EXPERT
It could be, but try moving the #2 to a different cylinder and see if the problem moves with it. If it does or doesent you know what to do.
Was this
answer
helpful?
Yes
No
Monday, February 25th, 2008 AT 5:45 AM

Please login or register to post a reply.

Recommended Guides