1992 Toyota MR2 timing belt

Tiny
VROOMR2
  • MEMBER
  • 1992 TOYOTA MR2
  • 4 CYL
  • 2WD
  • MANUAL
  • 171,000 MILES
Just replaced timing belt. I followed instructions on the manual and I also made sure that I was on tdc. When I started the car it sounded good then when I drove it its like loosing power and the car has no acceleration.
Do you
have the same problem?
Yes
No
Tuesday, June 24th, 2008 AT 9:29 AM

5 Replies

Tiny
DOCFIXIT
  • EXPERT
Did you turn engine over by hand a few times and recheck alignment? Sometimes you think you got it but due to the tenisioner and how belt was routed they get off a few teeth and she don't have no get up. Also did you check to see if any valves may have been bent can.T recall if this is an interference engine ore not. Let us know
Was this
answer
helpful?
Yes
No
Tuesday, June 24th, 2008 AT 9:46 AM
Tiny
VROOMR2
  • MEMBER
Yes I did rotate engine by hand, made 2 turns and it was still align. Also that while in nuetral I step on the gas and it doesnt rev normal. Rpm wont even reach 4000rpm
Was this
answer
helpful?
Yes
No
Tuesday, June 24th, 2008 AT 2:43 PM
Tiny
VROOMR2
  • MEMBER
Oh I forgot to mention the first time I installed the belt the car didnt start then I figured it wasnt align then redid it again and it started but with problems I have mentioned earlier.
Was this
answer
helpful?
Yes
No
Tuesday, June 24th, 2008 AT 9:10 PM
Tiny
VROOMR2
  • MEMBER
It's non interference.
Was this
answer
helpful?
Yes
No
Friday, June 27th, 2008 AT 5:33 PM
Tiny
DOCFIXIT
  • EXPERT
Lets go for basics check puel pressure and coil spark should be blue/white. Also put timing light rev does it advance 38 deg at 3000rpm.
Let me know
Was this
answer
helpful?
Yes
No
Saturday, June 28th, 2008 AT 10:01 AM

Please login or register to post a reply.

Recommended Guides