1997 Toyota Camry A/C & Cooling fans do not come on

Tiny
JUSTO
  • MEMBER
  • 1997 TOYOTA CAMRY
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 177,000 MILES
I just put in a new radiator, thermostat & coolant temp switch. I also tested the main eng. Relay, & cooling fan relay no. 1, they tested ok.I also checked for any blown fuses relating to this issue, all fuses are fine.I cant even get the A/C fan to turn on, when a/c is in use.I also ran power to both fans directly from the battery, they both turned fine. Any suggestions would be appreciated. Justo
Do you
have the same problem?
Yes
No
Saturday, April 26th, 2008 AT 7:57 PM

3 Replies

Tiny
2CIXPT
  • MEMBER
Since you know how to test relays below is your EWD on the cooling fans.


https://www.2carpros.com/forum/automotive_pictures/12900_f1_3.jpg




https://www.2carpros.com/forum/automotive_pictures/12900_f2_2.jpg

Was this
answer
helpful?
Yes
No
+3
Monday, January 25th, 2021 AT 12:40 PM
Tiny
JUSTO
  • MEMBER
Reply,

Thanks, for sending the ewd.

My Haynes repair manual has one as well.

Could my problem be a bad a/c pressure sw or maybe the diodes on the water temp sw no.1 line?

I don't know what else to try, is there something else that I maybe overlooking?

Please advise.

Thanks,

Justo
Was this
answer
helpful?
Yes
No
Monday, January 25th, 2021 AT 12:40 PM
Tiny
2CIXPT
  • MEMBER
Try a jumper on each switches in the diagram. Still the same could be the computer.
Was this
answer
helpful?
Yes
No
-1
Monday, January 25th, 2021 AT 12:40 PM

Please login or register to post a reply.

Sponsored links