4Runner heater fan motor

Tiny
JEKRUG
  • MEMBER
  • TOYOTA 4RUNNER
I have a '93 4Runner 4WD, V6, with 159000 miles. All of a sudden the medium position of the heater motor switch stopped working. Is this repairable? Could this be fuse related? How do I remove the switch panel from the dash to repair/replace the switch?
Do you
have the same problem?
Yes
No
Tuesday, July 31st, 2007 AT 8:52 AM

3 Replies

Tiny
RASMATAZ
  • MEMBER
Try checking the blower resistor at left side of blower housing if not it check the control switch.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2007 AT 5:16 PM
Tiny
HUDSONHORNET
  • MEMBER
[quote="rasmataz"]

Ok I had this Exact problem with my 93' 4runner. First I went to a junk yar, found a 4runner, pulled out the blower switch control thing. Payed 5 bucks for it. This is good, because:
1. Gives you a chance to take apart the dash and pull out the piece without risking your vehicle.
2. The piece from a toyota dealer ship is $57. ( I checked)

The hardest part of removing the switch from the dash is that you need to remove the dash board(couple of screws) then the radio (couple of bolts and wires) and then all the tabs on the switches, then pull off the faceplate over the switches.
Now from this point its kinda just guess work, atleast for me, just remember that plastic bends a decent amount. Be carefull not to break the little light above the switches, and double check to make sure that it still works before you put your dash together again. I forgot to plug it in, and its not worth my time to take apart my car again.

But other then the light, the new switch works and I have heat and A/C again
Was this
answer
helpful?
Yes
No
Wednesday, August 1st, 2007 AT 5:35 PM
Tiny
HUDSONHORNET
  • MEMBER
And by junk yard, I mean a car junk yard.
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2007 AT 2:40 AM

Please login or register to post a reply.

Recommended Guides