1999 Toyota 4Runner Miss fire

Tiny
DUDE1888
  • MEMBER
  • 1999 TOYOTA 4RUNNER
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 139,000 MILES
When I start my 4runner in the morning or when the engine is cold, it runs perfectly and will continue to do so for as long as it is running. But if I stop and turn it off, it missfires in the #1 cyclinder. This is ony afetr it is warm. After about 5-10 mins of driving it will eventualy smooth out until I stop again. The check engine is on and the code is P0171.

Just a recap:
Runs fine when cold and will continue for as long as I drive it

Misses when turned turned off and sit for about 15mins and turn back on, and it really runs kike crap.

Will smooth out after about 5-10 mins of dirving until I turn it off again.

Does this sound like an MAS?
Do you
have the same problem?
Yes
No
Saturday, August 16th, 2008 AT 9:37 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
P0171/P0301

A lean fuel condition can be caused by:

* Low fuel pressure due to a weak pump or leaky fuel pressure regulator. (Use a fuel pressure gauge to check fuel pressure at idle)

* Dirty fuel injectors. (Try cleaning the injectors)

* Vacuum leaks at the intake manifold, vacuum hose connections or throttle body. (Use a vacuum gauge to check for low intake vacuum)

* Leaky EGR valve. (Check operation of EGR valve)

* Leaky PCV Valve or hose. (Check valve and hose connections)

* Dirty or defective Mass Airflow Sensor (MAF). (Try cleaning the MAF sensor wires or filament with aerosol electronics cleaner. Do NOT use anything else to clean the sensor, and do not touch the sensor wires)

P0301 check the sparkplug/injector/compression on that cylinder
Was this
answer
helpful?
Yes
No
Sunday, August 17th, 2008 AT 7:06 AM
Tiny
DUDE1888
  • MEMBER
Now I'm getting a constant #4 missfire, code 0304. I chaanged the MAS, moved the coil, changed the wires changed the plugs. Still the same thing, when I start it when it's cold it will run fine until I shut it off. It won't just start to miss while it's running, it's only after I shut it off. When I start it again it's starts missfiring on #4. This thing is driving crazy.
Was this
answer
helpful?
Yes
No
Monday, August 18th, 2008 AT 9:45 PM
Tiny
RASMATAZ
  • MEMBER
Check the no.4 compression and injector/s Recheck the coil packs.
Was this
answer
helpful?
Yes
No
-1
Tuesday, August 19th, 2008 AT 12:44 PM

Please login or register to post a reply.

Recommended Guides