1989 Toyota 4Runner fuel injection

Tiny
BEACHCOMBER4YOU
  • MEMBER
  • 1989 TOYOTA 4RUNNER
Engine Mechanical problem
1989 Toyota 4Runner 6 cyl Four Wheel Drive Automatic 169 th miles

Hello,
This engine ran before I changed bad head gaskets and install new fuel injectors. Problem is Engine will not start. The injector resistance tests ok 13.7 Ohms
Tested injector circuit with NOID TEST LIGHT - Test ok. Can hear injectors clicking while engine is being turned over. Engine will fire, I believe off of cold start injector and then die. At this point I'm out of ideas. Any help will be greatly Appreciated.

M. Genzano
Do you
have the same problem?
Yes
No
Saturday, May 22nd, 2010 AT 6:55 PM

8 Replies

Tiny
MHPAUTOS
  • EXPERT
Hi there, have you check fuel pressure at the rail? Are there any set fault codes coming up in the ECU?

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Saturday, May 22nd, 2010 AT 9:09 PM
Tiny
BEACHCOMBER4YOU
  • MEMBER
I have no tester to check for fault codes. What kind of tester will I need? What will codes tell me?
Was this
answer
helpful?
Yes
No
Saturday, May 22nd, 2010 AT 10:44 PM
Tiny
MHPAUTOS
  • EXPERT
Hi there,

You will need an OBD 11 scanner with a Toyota interface, the ecu will hold set fault codes for any system that it controls, if one or more of these systems are out of parameter or not sending reference signals, you will get a dedicated fault code for that system.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Saturday, May 22nd, 2010 AT 11:40 PM
Tiny
BEACHCOMBER4YOU
  • MEMBER
Good Morning,
First of all, Thank you for all you help. Can this test be done without the engine running?

M. Genzano
Was this
answer
helpful?
Yes
No
Sunday, May 23rd, 2010 AT 9:02 AM
Tiny
MHPAUTOS
  • EXPERT
Yes, you just need the ignition on.

Mark
Was this
answer
helpful?
Yes
No
Sunday, May 23rd, 2010 AT 9:35 PM
Tiny
BEACHCOMBER4YOU
  • MEMBER
Hello mhpautos,
!989 Toyota will still not keep running. Engine will start right up and the die. I have checked all that I will list for you.
1-fule pressure = 40PSI
2-injector resistance = 13.7 Ohms
3-Node light test = goog
4- can hear injectors clicking while enging is being cranked over
5-No codes come up on Ck. Engine light
With all this being tested it still wont stay running. Any suggestions would be greatly appreciated.
GOG BLESS YOU AND FAMILY IN JESUS NAME A=MEN!!

M.Genzano


http://www.2carpros.com/forum/automotive_pictures/530367_Master_Mechanic_2.jpg

Was this
answer
helpful?
Yes
No
Thursday, May 27th, 2010 AT 3:03 PM
Tiny
MHPAUTOS
  • EXPERT
Hi there, OK next is to check that the spark is good and hot and clean the plugs as if the engine is not firing and the fuel system is OK as it seams it is, the plugs will be rather fuel fouled by now and that will also be a problem, let me know what the plugs look like.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Thursday, May 27th, 2010 AT 6:30 PM
Tiny
BEACHCOMBER4YOU
  • MEMBER
Hello mhpautos,
I checked spark and it is strong. Spark plugs were damp. I had installed all new plugs from the begining.
I found out something while experimenting, If I put a jumped across +B - Fp ,and pump the gas peddle after engine fires as it has in the past ,I can keep the engine running for a longer period of time, but still wont stay running.
HAVE A GREAT WEEK END AND GOD BLESS IN JESUS NAME A=MEN!!!
M.Genzano


http://www.2carpros.com/forum/automotive_pictures/530367_Master_Mechanic_3.jpg

Was this
answer
helpful?
Yes
No
Friday, May 28th, 2010 AT 4:05 PM

Please login or register to post a reply.

Recommended Guides