Surging Idle in gear

Tiny
TRISTANBOYD
  • MEMBER
  • 2007 FORD FREESTAR
  • 3.9L
  • V6
  • FWD
  • AUTOMATIC
  • 105,000 MILES
Idles normal but with a rattling noise in Park and surges when in gear with the brake pressed. If I unplug the TPS (replaced due to a code present) the noise goes away within a few seconds, but it still surges. If I unplug the IACV (also replaced) the surging stops and it runs as it should. If I unplug them both, there is no noise and no surging. There are no codes present since the TPS has been replaced. I'm including a link to a video showing the above.

https://www.youtube.com/watch?v=wJXlaEF2T5k
Do you
have the same problem?
Yes
No
Wednesday, March 1st, 2017 AT 4:03 PM

3 Replies

Tiny
HMAC300
  • EXPERT
Try cleaning the throttle plate on both sides and shaft area as well as iac hole with choke cleaner. Then check for a loose torque converter bolt/nut and loos shields in engine area.
Was this
answer
helpful?
Yes
No
Thursday, March 2nd, 2017 AT 6:58 AM
Tiny
TRISTANBOYD
  • MEMBER
I took the throttle body off and gave it a thorough cleaning. It was pretty dirty. No change in the surging. Still surges with the IAC plugged in and stops when it's unplugged. We have noticed that it doesn't do it until the engine heats up to operating temperature
Was this
answer
helpful?
Yes
No
Sunday, March 5th, 2017 AT 10:38 PM
Tiny
HMAC300
  • EXPERT
Scan for codes or have you done that already also check for a vacuum leak. Get back to us with any codes. Also check duct work between air cleaner and engine if any holes replace it as that can cause it as well.
Was this
answer
helpful?
Yes
No
Monday, March 6th, 2017 AT 6:22 AM

Please login or register to post a reply.

Sponsored links