Air Conditioner Problem

Tiny
KAMISHKI
  • MEMBER
  • SUBARU
Subaru
Outback XT Limited
(Turbo with dual Climate control system)
2005
13,000 Miles
2.5 L

Since the car was new the Air Conditioner has been inadequate. I have determined that the compressor kicks in and out every 10 seconds.

I know R134a needs to cycle but every 10 seconds?

The Subaru dealer is DENSE. I have brought it to the three times and they measure the temp and say everything is normal. They said that the compressor didn't cycle on them (I can not see how!) You can feel it, you can hear it in the car, and you can hear the distinct CLICK right at the compressor when it kicks in and you can hear a different more muffled sound when it kicks off. The air in the vent gets VERY cold, then warms, then very cold then warm.10 seconds each like clock work.

It makes no difference what the outside temp is, or if it is humid.

I have tested with many settings including "MAX" (65 degrees and recirc.)


Can anyone make a recomendation as to what may cause this? I know my Toyota, also with 134a blows consistently cold.
Do you
have the same problem?
Yes
No
Sunday, July 1st, 2007 AT 8:12 AM

1 Reply

Tiny
MOPAR MAN
  • MEMBER
If do not trust the Subaru dealer is there a independent shop that does A/C work you know of? Or a shop that just does auto A/C in town?
Yes the A/C will cycle off and on that is normal. Most of the time when they get low they cycle more often.
Knowing how much freon is in todays A/C system's is a MUST then the problem can be found.

Hope I helped some.
Was this
answer
helpful?
Yes
No
Monday, July 30th, 2007 AT 7:11 PM

Please login or register to post a reply.

Recommended Guides