2000 Subaru Legacy blinkers, odometer, etc not working

Tiny
BACKPACKER
  • MEMBER
  • 2000 SUBARU LEGACY
2000 Subaru Legacy 130, 00 miles

My daughter recently hit a deer with her Subaru. The impact broke the driver's side headlight assembly but apparently nothing else. However, the blinkers and odometer no longer work, and the check engine light, which was on, is no longer. The wipers seem to run slow too. I checked the fuses and all seem fine. I don't know about the relays though, as I don't know how to check them. I should mention that just before the accident, I replaced the alternator and had the battery unhooked to have it checked for voltage. In doing so, I did cause quite a spark when the battery cables came in contact with the terminals. Did I fry something then?
Do you
have the same problem?
Yes
No
Wednesday, December 17th, 2008 AT 1:31 PM

8 Replies

Tiny
M_H_RITZEL
  • EXPERT
With reference to the engine light when you disconnected the battery it reset the computer, After being driven about 50 miles it will have reset itself. If there is a problem the engine light will come back on. The blinkers may have a bad ground or broken wire, check the wires and sockets. On my subaru I had to clean out the socket to get a good connection. With reference to the wipers running slow, With vehicle running disconnect the battery, the car should run with out the battery hooked up. If not have the charging system checked at someplace like auto zone or any other parts supplier. The will check it for nothing.
Was this
answer
helpful?
Yes
No
Wednesday, December 17th, 2008 AT 10:56 PM
Tiny
BACKPACKER
  • MEMBER
Thanks for your answer. But why would the digital odometer not work? Could this be the result of a bad relay?
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 7:19 AM
Tiny
M_H_RITZEL
  • EXPERT
You said that you had a spark when the you replaced the altinator, It may be just a fuse. Check the fuses on the drivers kick panel
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 8:35 AM
Tiny
BACKPACKER
  • MEMBER
I believe the odometer and blinkers were working before the deer accident (still waiting for confirmation on that). Damage was not excessive, just bent the fender and broke the headlight assembly. The battery connection was still good. I checked the fuses under the hood and they were fine.
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 8:56 AM
Tiny
M_H_RITZEL
  • EXPERT
There are fuses under the hood and also by the drivers side kick panel, the ones under the hood have relays for the headlights. There is also a fuseable link towards the frontof the box.
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 1:21 PM
Tiny
BACKPACKER
  • MEMBER
I'm sorry, I forgot to mention that I checked out the fuses under the dash that I thought would be relevant. They were fine. That's why I keep asking about the relays. Fusable link?
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 2:58 PM
Tiny
M_H_RITZEL
  • EXPERT
I tried to download you a diagram of the relays under the hood. I had just came back from off this website because of moving and was unable. I looked it up. The fusable link in that compartment runs such as the ignition switch. That are 5 in there run the a/c, rt and left head light.
The one for the directionals is on the bottom kick panel inside the car on the drivers side. Just above the fuse box. Directly above the hood release lever. To get at it you have to take down the hood release lever and on top of the relay is a screw that holds it in place. Sorry I could not download the pictures.
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 6:39 PM
Tiny
BACKPACKER
  • MEMBER
Thanks for your help. I will look at it again this weekend. I assume that I will be able to tell if something is wrong with the fusable link once I pull it out.
Was this
answer
helpful?
Yes
No
Friday, December 19th, 2008 AT 6:46 AM

Please login or register to post a reply.

Recommended Guides