Stiff brake pedal

Tiny
CONAGHER
  • MEMBER
  • 1965 GMC C3500
  • V6
  • 2WD
  • MANUAL
  • 350,000 MILES
New master, rebuilt vacuum 2018, rebuilt wheel cylinders 2010. Brake pedal is stiff with zero travel.
Do you
have the same problem?
Yes
No
Monday, November 5th, 2018 AT 1:37 PM

9 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good afternoon.

Do you have vacuum to the booster? Remove the hose and verify there is vacuum.

If you have a vacuum gauge, check the amount of vacuum to the booster.

Does the linkage move freely? Look under the dash and be sure the pedal and rods move freely.

Roy
Was this
answer
helpful?
Yes
No
Monday, November 5th, 2018 AT 1:49 PM
Tiny
CONAGHER
  • MEMBER
Pedal travels freely while l bench bleed master, will not travel with brake line attached. I will check for vacuum.
Was this
answer
helpful?
Yes
No
Monday, November 5th, 2018 AT 1:57 PM
Tiny
ASEMASTER6371
  • EXPERT
Sounds like a plan. Keep us posted.
Was this
answer
helpful?
Yes
No
Monday, November 5th, 2018 AT 2:16 PM
Tiny
CONAGHER
  • MEMBER
Vacuum at Hydro vac verified, seemed to be strong. Brake pedal travels when brake line disconnected. Clutch side of master is functioning as designed.
Was this
answer
helpful?
Yes
No
Monday, November 5th, 2018 AT 3:18 PM
Tiny
ASEMASTER6371
  • EXPERT
Sounds like you have an issue with the hydro-vac unit.

Clutch side of master is functioning as designed. Can you explain this?
Was this
answer
helpful?
Yes
No
Monday, November 5th, 2018 AT 3:23 PM
Tiny
CONAGHER
  • MEMBER
Hydro Vac rebuilt and new master cylinder installed both in November 2018. Slave cylinder on clutch side of master working as designed. All four Wheel cylinders rebuilt in 2010.
Was this
answer
helpful?
Yes
No
Monday, November 5th, 2018 AT 3:30 PM
Tiny
KEN L
  • ADMIN
It sounds like you have an issue with one of the brake flex hoses. They can become clogged internally. Here is a video of how to replace the brake hoses:

https://youtu.be/xMS8Xy4Xz1U

Please run down this guide and report back.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+1
Thursday, November 8th, 2018 AT 12:05 PM
Tiny
CONAGHER
  • MEMBER
I fixed this issue yesterday suspecting the same thing, a clogged line. Pedal travels freely when brake line disconnected, stiff when line is connected. Pulled line between master and Hydro-Vac and discovered flex portion of line to be clogged.

Thanks for the help!
Was this
answer
helpful?
Yes
No
Thursday, November 8th, 2018 AT 5:06 PM
Tiny
KEN L
  • ADMIN
Glad you could get it fixed, that kind of problem can be tough. Please use 2CarPros anytime we are here to help.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Friday, November 9th, 2018 AT 11:13 AM

Please login or register to post a reply.

Sponsored links