Starts fine, but then shuts off while driving?

Tiny
OLASTERRI
  • MEMBER
  • 2007 RENAULT TRAFIC
  • 2.0L
  • 6 CYL
  • 2WD
  • MANUAL
  • 127,158 MILES
It starts every time, the first time when it's cold I can drive it for around 10 minutes, but then suddenly stops. When I try to start it again it starts, but stops right after. What can it be?
Do you
have the same problem?
Yes
No
Saturday, September 30th, 2023 AT 2:01 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 107,591 POSTS
Hi,

Please understand, this vehicle isn't offered in the US. However, I will try my best to help.

It sounds like it could be a few things. Have you checked fuel pressure to confirm it is within the manufacturer's specifications? Also, the idea that it doesn't want to run after driving it that far could be related to a faulty crankshaft position sensor.

Do me a favor. Take a look through this link and let me know if anything mirrors what you experienced:

https://www.2carpros.com/articles/symptoms-of-a-bad-crankshaft-sensor

Let me know.

Take care,

joe
Was this
answer
helpful?
Yes
No
+1
Saturday, September 30th, 2023 AT 9:59 PM
Tiny
OLASTERRI
  • MEMBER
  • 2 POSTS
Thanks. It's exactly what's happening that was stated in the link. I ordered both a camshaft sensor and crankshaft sensor. So now I'm waiting for it to replace.
Was this
answer
helpful?
Yes
No
Sunday, October 8th, 2023 AT 7:45 AM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 107,591 POSTS
Hi,

You are very welcome. If you have a chance, let me know how things turn out for you. I'm interested in knowing.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Sunday, October 8th, 2023 AT 1:55 PM

Please login or register to post a reply.

Sponsored links