Starting and OBD connection

Tiny
DECAPTAIN2010
  • MEMBER
  • 2006 LEXUS RX 400H
  • 3.3L
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 98,000 MILES
While washing the back seat water drop into the battery area and burnt the battery relay assembly but I bought another one and later found the main ECM under the dash to be affected. I also changed it but upon reprogramming there is no communication, but there was check engine light when you on ignition. Again sometimes when you start a noise sound from the traction battery area. Please how do I get communication and is the battery connected to the invert-er?
Do you
have the same problem?
Yes
No
Tuesday, June 20th, 2017 AT 3:44 AM

1 Reply

Tiny
KEN
  • ADMIN
Hello,

Usually the non communication problem is because one or more of the computers are not powering up. They is several relays that must activate to achieve this. Here are some guides and the complete engine and battery wiring so you can do some testing.

Make sure you stay away from the high voltage portion of the system (large wires). If your not sure don't go any further.

Here are the complete wiring diagrams for the engine and batteries for your car (below).

As you can see there are many relays and a circuit breaker that could be causing the problem.

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

And

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Please let us know what happens, we are interested to see what it is.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Thursday, June 22nd, 2017 AT 3:51 PM

Please login or register to post a reply.

Sponsored links