When driving the car, when it gets warm it keeps stalling and it runs rough

Tiny
TERRI GRATTON LABERGE
  • MEMBER
  • 1998 OLDSMOBILE 98
  • 3.8L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 40,000 MILES
The guys that are trying to fix our car are mechanics. They have changed different parts that was thought could be the problem but turned out it wasn't they looked like they needed changing though. New plugs have been put in, a new fuel filter (the old was really dirty) and a few other things but I don't know what more. We've been told our electrical system is fine. No one is giving up and changing what we did was a good thing for the car, but we are trying to figure out ideas that might be the right problem.
Do you
have the same problem?
Yes
No
Thursday, April 14th, 2022 AT 5:56 AM

3 Replies

Tiny
JOE F
  • EXPERT
Hi,

If this only happens when the vehicle is warm, it sounds like the crankshaft position sensor is failing. Has that been replaced? Are there any diagnostic trouble codes that were retrieved?

Let's start here. Take a look through this link and let me know if it seems to mirror what you experience:

https://www.2carpros.com/articles/symptoms-of-a-bad-crankshaft-sensor

Let me know your thoughts.

Take care,

Joe
Was this
answer
helpful?
Yes
No
-1
Thursday, April 14th, 2022 AT 8:02 PM
Tiny
TERRI GRATTON LABERGE
  • MEMBER
Yes, we have already changed the crankshaft position sensor.
Was this
answer
helpful?
Yes
No
Saturday, April 16th, 2022 AT 4:32 PM
Tiny
JOE F
  • EXPERT
Terri,

Do you know if the ignition control module was inspected? That is the component on which the ignition coils are mounted.

If possible, can you let me know what all has been done, checked, or replaced?

If the module wasn't checked, that is my next suggestion. I attached a pic below showing the part I'm referring to.

Let me know, and I hope you have a nice Easter.

Joe

See pic below.
Was this
answer
helpful?
Yes
No
Saturday, April 16th, 2022 AT 7:07 PM

Please login or register to post a reply.

Sponsored links