Speedometer not working

Tiny
HHUGHES0320
  • MEMBER
  • 1991 NISSAN MAXIMA
  • 3.6L
  • V6
  • 2WD
  • MANUAL
  • 214,000 MILES
I have previously replaced the whole instrument panel about 5 years ago.
the speedometer is not working, tachometer is good.
odometer is intermittent.
Do you
have the same problem?
Yes
No
Monday, November 2nd, 2020 AT 10:39 AM

3 Replies

Tiny
KASEKENNY
  • EXPERT
More then likely this is the speed sensor or cluster. So we need to test the speed sensor as shown and if it passes then we need to suspect the cluster again.

Let's do this test and go from there. Thanks
Was this
answer
helpful?
Yes
No
Monday, November 2nd, 2020 AT 5:34 PM
Tiny
HHUGHES0320
  • MEMBER
Hello, I took the speed senor out and put it on a multimeter set for AC.
I could spin the gear and see that it was generating a AC voltage.

The speedometer and odometer are not working and the needle for the speedometer is not at zero mph, but buried on the right side of the dial at about 5:30pm.

I can take the cluster out and look at it. Any strategy there?
Clean contacts, put the needle back on left side?
Thanks for your help and assistance.
Howard
Was this
answer
helpful?
Yes
No
Tuesday, November 3rd, 2020 AT 5:24 AM
Tiny
KASEKENNY
  • EXPERT
Okay. Assuming the sensor is generating the correct signal, I would just replace the cluster. You may be able to take it apart and try to clean contacts but I don't have a process for that nor have I done it. In fact, anytime I have had an issue with a cluster, I just replace it and don't even spend the time to try to make a repair to it.
Was this
answer
helpful?
Yes
No
Tuesday, November 3rd, 2020 AT 5:34 PM

Please login or register to post a reply.

Sponsored links