Speedometer

Tiny
PACHYAUTO63
  • MEMBER
  • 2000 GMC C3500
  • V8
  • 4WD
  • AUTOMATIC
  • 150,000 MILES
Is there a p-sensor in the transmission? I replaced all speed sensors and neutral switch, but when I drive the speedometer goes crazy up and down. What is going on?
Do you
have the same problem?
Yes
No
Friday, November 17th, 2017 AT 8:45 AM

5 Replies

Tiny
F4I_GUY
  • EXPERT
When you say you replaced all speed sensors, which sensors are you referring to? Did you replace the vehicle speed sensor located on the transmission output side or the wheel speed sensors located at each wheel?
Was this
answer
helpful?
Yes
No
Friday, November 17th, 2017 AT 1:34 PM
Tiny
PACHYAUTO63
  • MEMBER
Transmission output side.
Was this
answer
helpful?
Yes
No
Friday, November 17th, 2017 AT 1:55 PM
Tiny
JIS001
  • EXPERT
Is this an automatic? Also is the truck 4 wheel drive? If automatic do you know which transmission you have on here? Is it the 4L60E or the 4L80E?
Was this
answer
helpful?
Yes
No
Sunday, November 19th, 2017 AT 6:20 PM
Tiny
BARBARA1963
  • MEMBER
4l80e
Was this
answer
helpful?
Yes
No
Friday, November 24th, 2017 AT 1:29 AM
Tiny
KEN
  • ADMIN
The speedometer output signal is generated by the PCM but my guess is the speedometer is bad though is the connections are all good. Try to remove the cluster and remove the connector then plug the connector too in to see if it was a bad connection.

Here is a video how on to do it.

https://youtu.be/_HEC44xENxw

It also shows a rebuilt cluster getting installed.

Please let us know what you find. We are interested to see what it is.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Sunday, November 26th, 2017 AT 6:54 PM

Please login or register to post a reply.

Recommended Guides