When moving and turning, the traction control would come on and one of the front wheels would lose power?

Tiny
DAVID MARION
  • MEMBER
  • 2015 FORD EXPLORER
  • 2.4L
  • V6
  • 4WD
  • AUTOMATIC
  • 120,000 MILES
I purchased the vehicle listed above only to find that when moving and turning, the traction control would come on and one of the front wheels would lose power. This would only happen for a moment and then it would drive fine again. I took it to a transmission shop, and they diagnosed it as a bad PTU ($2,300). When I brought the car home, it was still doing it! I took it back and after a few days there they said that, for some reason, every speed sensor on the car would "blink" off for a moment. This happens when you turn the steering wheel while going over twenty MPH. They are at a loss as to why and are currently dealing with Ford, but no luck so far.
Do you
have the same problem?
Yes
No
Monday, August 8th, 2022 AT 6:11 AM

1 Reply

Tiny
KEN L
  • ADMIN
Bad PTU? Not sure what that is, anyway, it sounds like you have a bad front bearing hub which affects the ABS and traction control system. This problem would be intermittent, which is why Ford can't find it. Here is how I would fix it in the diagrams below. Replace both front hubs. Check out the diagrams (below). Let us know what happens and please upload pictures or videos of the problem.
Was this
answer
helpful?
Yes
No
Monday, August 8th, 2022 AT 4:49 PM

Please login or register to post a reply.

Sponsored links