2001 Saturn SL2 Valve body replacement

Tiny
CROTH1203
  • MEMBER
  • 2001 SATURN SL2
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 130,000 MILES
Just replaced my valve body bc of all the hard shifting. Made sure the manual lever positioning switch was adjusted and im still having a few problems. 50% of the time it will run ok and the other it will start shifting hard again. Whille driving, and starting out in d2 and going to d3 and then to d its pretty smooth but if I start out in d it is still shifting hard. Even in reverse it, it shifts hard sometimes but not all the time. Im I missing something or forgetting to check something else? Im lost and out of idea's? Maybe vehicle sensor? Computer problem? Thank you for any suggestions or ideas.
Do you
have the same problem?
Yes
No
Tuesday, May 18th, 2010 AT 4:32 PM

10 Replies

Tiny
SATURNTECH9
  • EXPERT
Do you have a delay into reverse?Do you have any codes?Let me know.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 18th, 2010 AT 8:35 PM
Tiny
CROTH1203
  • MEMBER
There is a slight delay in reverse. Seems like it will shift better into reverse when it sits awhile. But I did notice my rpm were sitting around 1200 also. Wondering if that has anything to do with it. Seems like something is just off a little for it to work sometimes and then to be banging again. Will get codes checked tomo. What is the best way to test it for codes? Local autozone? Or is there a way I can test it? Thank you for your help.
Was this
answer
helpful?
Yes
No
Tuesday, May 18th, 2010 AT 9:39 PM
Tiny
SATURNTECH9
  • EXPERT
You have to new of a car to flash the codes out you will have to go to a place where they can scan your codes for you. The reason everything works better with your transmission when it sits is because the fluid is cooler and thicker. Those rpms shouldnt have anything to do with your problem. When you replaced your valve body did you tourqe it to the right torque. Also the right tourqe pattern?Where did you get the valve body from?Let me know.
Was this
answer
helpful?
Yes
No
Wednesday, May 19th, 2010 AT 2:10 PM
Tiny
CROTH1203
  • MEMBER
Torqued the bolts to 97 inch-pounds. Tighten one bolt on one side and then tighten the opposite one next. Is there a certain pattern you have to follow? Bought the valve body through Valve body Express and then Transtar Industries, Inc shipped it. I have an appointment tomo morning to get it scanned. Also today I could here with my window down, when I put it into D2 a whining sound and a few clicks were coming from the valve body. I know the manual Valve was inserted with the plastic clip facing towards the front of the car and then hooked back up the Manual valve link. Sure sounds like something is coming from that. Wondering if that could be my problem bc I never did hear that before. Thanks again.
Was this
answer
helpful?
Yes
No
Wednesday, May 19th, 2010 AT 6:04 PM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_valve_body_installation_part1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_valve_body_installation_part2_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_valve_body_bolt_postion_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_valve_body_bolt_tourqe_sequence_1.jpg


Theres the installation process,the tourqe sequence,and the bolt location.You have the right tourqe though.Did you get the dowl bolts in the right location?As far as your noise goes sounds like your transmission actuators are just engaging which they make noise when they do that perfectly normal.you could have gotten a bad valve body even i have gotten bad ones that were factory reconditioned even but were not there yet to say that.Let me know what you find.
Was this
answer
helpful?
Yes
No
Wednesday, May 19th, 2010 AT 6:31 PM
Tiny
CROTH1203
  • MEMBER
Thank you for the diagrams. Yes, got dowel rods in correct spot. Took them out and put them straight into new one. Took car to get scanned today and they said they had a little bit of confusion with scan. The scan said the Pressure Control Solenoid is off and which they said they couldnt scan the engine the main computer was throwing a code saying the same thing. They said they couldnt determine if the Pressure Control Solenoid is bad in the valve body or my car computer is having problems. They said they needed to dig deeper and wanted to start charging me a lot of money. I had them stop. There quote for hours that it may take them to figure out was really off, since I know how long it takes to install one. Is it worth the money to get engined scanned to check my computer or would it be in my best interest to go ahead and install a new Pressure Control Solenoid? It is the first solenoid, that is towards the front of the car? Thanks so much.
Was this
answer
helpful?
Yes
No
-1
Thursday, May 20th, 2010 AT 7:47 PM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_p0746_part1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_p0746_part2_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_p0746_part3_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_transmission_wire_diagram_1.jpg


I dont know what code you have i just posted the trouble tree for code p0746 pessure control solindo low voltage so you could read about how it worked and kinda get an idea of how it works.I want you to check the trs Lp fuse in the underhood fuse box it wont have power you will have to visually inspect it.Thats your line pressure fuse.Also remove the connector to the valve body look at the back of plug comming off the engine harness its labeled with letters.Use it as a guide to find terminials F and G on the valve body connector bus plate take your ohm meter on 200 ohm scale and read the value across those two terminials it should be 3.8-7.2 ohms that will check your line pressure actuator electricialy.That doesnt make sense that they cant talk to your computer because supposedly your line pressure solindo is turned off never heard of that one.You need to get some codes out of your car though.You could have a problem with your wires going to your actuators even and that could have been your problem all a long and not your valve body.Iam not saying for sure but that is a possibilty.So did you try going to autozone just for a code scan?Let me know what you find.
Was this
answer
helpful?
Yes
No
Thursday, May 20th, 2010 AT 9:11 PM
Tiny
CROTH1203
  • MEMBER
Thank you for all the great info. I will try out everything as soon as I get off of work tomo. I didnt go to autozone yet bc they said if it is my computer that isnt working, that their scanner would not be able to pick that up. I will hold off on going to this other shop and go over to autozone at lunch tomo and start with that first and see what codes they come up with. I will let you know what they come up with. Thanks again for all the great help.
Was this
answer
helpful?
Yes
No
Thursday, May 20th, 2010 AT 10:20 PM
Tiny
CROTH1203
  • MEMBER
Made it to autozone and codes were P0732 and P0782. I havent been able to check anything else today bc of thunderstorms and I dont have a garage. From these codes where would you recommend that I start at? Thanks again.
Was this
answer
helpful?
Yes
No
+1
Friday, May 21st, 2010 AT 5:36 PM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0732_part1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0732_part2_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001sl2_code_p0732_part3_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0732_part4_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0732_part5_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0782_part1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0782_part2_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_2001_sl2_code_p0782_part3_1.jpg


Thats pretty sad autozone got codes but that shop couldn't.If you read the code p0732 it says that a 3rd gear solindo issue can cause the p0732 code.So start with the code p0782.The terminials you need for 3rd gear solindo on the valve body bus plate is A and B check it for ohms like i told you to check for the pressure control solindo.Let me know what you find.
Was this
answer
helpful?
Yes
No
+1
Friday, May 21st, 2010 AT 8:57 PM

Please login or register to post a reply.

Recommended Guides