2001 Saturn SL2 engine

Tiny
HAMID596
  • MEMBER
  • 2001 SATURN SL2
Engine Performance problem
2001 Saturn SL2 4 cyl Front Wheel Drive Automatic

engine starts then stops immediately
Do you
have the same problem?
Yes
No
Thursday, April 1st, 2010 AT 8:28 AM

7 Replies

Tiny
SATURNTECH9
  • EXPERT
First of all thank u so much for ur donation it really helps to keep this site going and answering everyones questions. So when it starts and dies does it always do this or only when cold or hot?Do u have any codes?If u hold ur foot to the floor while trying to start it will it start and clear out itself or run better?Let me know.
Was this
answer
helpful?
Yes
No
Thursday, April 1st, 2010 AT 10:52 AM
Tiny
HAMID596
  • MEMBER
Always does it
no codes
foot toflore does not matter
starts and quites as many times as you want to it
Was this
answer
helpful?
Yes
No
Thursday, April 1st, 2010 AT 11:43 AM
Tiny
SATURNTECH9
  • EXPERT
When u turn ur key on where does ur temp gauge read all the way to cold or somewhere else?Also have u tried spraying carb spray in ur throttle body to see if it starts any better?When it starts and dies about how does it run?
Was this
answer
helpful?
Yes
No
Thursday, April 1st, 2010 AT 12:10 PM
Tiny
HAMID596
  • MEMBER
Temp gauge cold all the time carb spray does not help
runs for 3-4 sec. Joe
Was this
answer
helpful?
Yes
No
Thursday, April 1st, 2010 AT 3:05 PM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_2001_coolant_temp_sensor_1.jpg


ok if it runs for 3-4 seconds i would say it has spark.we dont know how much fuel pressure it has though it might be too low to keep running.also u could have a bad coolant temp sensor very common for these cars will cause no starts dieing surging unstable idleover heating.its figure 6 on the diagram i posted.if u had a scanner that could read engine data u could read engine temp and see if it was within 10 degrees of actual temp.the sensors are only like 10 and easy to change they just screw into the head.they also leak and corrod the the connector if urs is corroded then u will have to replace the connector.if u could get a scanner that would read engine temp that would be great then u could see if it read within 10 degrees of the actual coolant temp of the coolant bottle temp.if not u could try changing the sensor.if u change the sensor becarefull u will loose coolant.also make sure u replace it with a brass tipped one not a plastic tipped they crack and leak into the connector.if all that is good i would check ur fuel pressure next.let me know what u find.
Was this
answer
helpful?
Yes
No
Thursday, April 1st, 2010 AT 9:33 PM
Tiny
HAMID596
  • MEMBER
I put new fuel filter a diffent fuel pump in I don't have a fuel pressure tester I put in new coolant sensor no diff. So put starting fluid in runs til
fluid runs out thanks Joe
Was this
answer
helpful?
Yes
No
Friday, April 2nd, 2010 AT 11:37 AM
Tiny
SATURNTECH9
  • EXPERT
Sounds like u have no fuel pressure now.A fuel pressure gauge is only like 20-25 we need to see how much fuel pressure u have. Sounds like thats where were at finding out if u have any fuel pressure then we can trace down power and ground. Let me know if u have fuel pressure.
Was this
answer
helpful?
Yes
No
Friday, April 2nd, 2010 AT 10:26 PM

Please login or register to post a reply.

Recommended Guides